there, in the weekly digest email it shows author

hi there,
1. in the weekly digest email it shows author of the post, ie.: by adam on 20 June, 2014

how could i remove 'by adam' and leave the date only?

2. i've set up a page /email-subscription and set it as a Subscribers Management Page. it says 'Users will receive a link to this page via email.' but i don't seem to get any email with this page. when i subscribe by email, i get an email and click to confirm that, but that's it.
when i go to /email-subscription it says: This page will show details of your email subscriptions. To see the options available to you, click the link in any newsletter email you have received from us

thanks,
Adam