Internal Server Errors caused by domain mapping recent update?

hey there,
I've been having many Internal Server Errors on my multisite since yesterday. I've contacted my server company and they've said, that most likely, domain-mapping plugin causes the issue. It seems that I run out of PHP processes, because domain-mapping plugin is constantly 'activating' admin-ajax.php script.

I've updated domain-mapping to the latest 4.3.0.4 yesterday, but just downgraded now.
What can I do to avoid this issue? My server environment is set up to the limits when it comes to php use, so perhaps I can set limits in wp-config or somewhere like that? That's what server company suggests, but I'm not sure what and how to do that.

I'd appreciate your help!

thanks,
Adam

admin 14677 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14755 9.0 3.2 185432 101676 ? R 04:16 0:01 /usr/local/php5/bin/php-cgi-real /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14767 0.0 0.0 17508 1400 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14769 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14770 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14772 0.0 0.0 17508 1400 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14774 0.0 0.0 17508 1400 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14775 0.0 0.0 17508 1400 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14779 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14780 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14781 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14782 0.0 0.0 17508 1400 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14783 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14784 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14787 0.3 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14788 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php
admin 14799 0.0 0.0 17508 1396 ? S 04:16 0:00 /bin/bash /usr/local/php5/bin/php-cgi /home/admin/domains/bandcloud.co.uk/public_html/wp-admin/admin-ajax.php

  • Ash
    • WordPress Hacker

    Hello @adam007

    I hope you are well today and thanks for asking the question.

    Are you in a shared hosting?

    Please go to Network Admin > Settings > Domain Mapping and disable cross domain auto-login. SSO needs some memory to process.

    Please let us know if that works for you.

    Cheers
    Ash

  • adam007
    • The Incredible Code Injector

    hey Ash,
    I'm on a cloud server, it's not shared. I think I have 3GB memory.
    I've disabled domain auto-login now and downgraded the plugin too, but the problem still persists and the server company still says that it seems to be something to do with domain mapping plugin.

    Cheers,
    Adam

  • adam007
    • The Incredible Code Injector

    When I deactivate domain mapping, everything works fine!
    Server company has suggested that the domain mapping plugin should have some memory limits set or I should somehow limit it. Any idea how I could do that?
    They have increased processes limits from 40 to 60, but apparently that's just a temporary fix.

    I've activated domain mapping plugin limits has been increased, and indeed, everything seems to work fine, so that indicates domain mapping issue.

    I'd appreciate your help on that!

    Cheers,
    Adam

  • Vaughan
    • Support/SLS MockingJay

    Hi Adam,

    Can you disable the domain verification check and see if that helps? We added some additional checking functions in the latest release which are tied to that admin option, we plan on creating a seperate setting for these new checks in an upcoming release, the new checks use a lot of resources if you have a few subsites unfortunately as the domains are verified constantly to check the propogation is correct, if the domain isn't propogated it automatically uses the original domain, if the propogation is done, it uses the mapped domain. But these checks are high on process usage.

    Hopefully that should resolve this issue until that new setting is added.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.