Strict Standards Errors on Upgrade

Hi there. I've been put in charge of a site that used your old popover plugin. I decided to upgrade and pay for the new PopUp Plugin but I can't seem to get anything to work without being plagued with Strict Standard errors, even on the webpages. So in the popover.php file I threw in a "error_reporting(0);" and it suppressed the errors for a stint. Now when I attempted to create a new popup and save it I got an error starting with; "Strict Standards: Non-static method IncPopupRules::init() should not be called statically". So, I deleted the new popup I created and it didn't go away. I cannot seem to get rid of the error message. Any thoughts?