There - Smush Pro

Hi There - Smush Pro says there are about 30 images that need to be smushed. I run it, and it never completes:

  • Predrag Dubajic
    • Support

    Hi Heidi,

    Thanks for granting support access, I checked your site and it seems that you have three images that have some broken thumbnails.
    These are the images in question:
    - Top-10-Security-Preview
    - CMS IoT Device Management
    - newCMSbackground-1400

    I would suggest trying to regenerate your thumbnails with a plugin like https://wordpress.org/plugins/regenerate-thumbnails/ or re-upload the images and then try running Bulk Smush process again.

    Let us know how it goes.

    Best regards,
    Predrag

  • Heidi
    • WPMU DEV Initiate

    Hi Sorry for the delay - it's been quite the journey and we're still not fixed.

    So I installed the regenerate thumbnails plugin and was about to turn it on but I wasn't sure about the settings. So I look through the support and I looks like a lot of people have issues with the plugin, but when they leave a question, it goes unanswered and then someone says the plugin author has terminal cancer. That's terrible for him, and I hope he's able to recover, but I'm not sure you should be recommending that plugin?

    I then try to find these images so I can re-upload them, but they don't exist on my site:

    Smushpro is still hanging and I'm not sure what to do?

    Thanks!
    Heidi

  • Adam Czajczyk
    • Support Gorilla

    Hello Heidi

    but when they leave a question, it goes unanswered and then someone says the plugin author has terminal cancer. That's terrible for him, and I hope he's able to recover,

    As much as I hate to say it, I'm afraid there's no good news. He passed away on February 27th. We're all deeply saddened in WP community :slight_frown:

    As for the plugin, it's still working fine and so far is a good tool that is worth recommending. To give it a go after installing and enabling it:

    - go to "Tools -> Regenerate Thumbnails" page in site's back-end
    - leave the "Skip regenerating existing correctly sized thumbnails" option enabled (checked)
    - make sure that "Delete thumbnail files for old...." option is disabled (unchecked)
    - click on "Regenerate Thumbnails for All Attachments" button

    and wait until the plugin completes processing.

    This should, hopefully, restore those missing thumbnails. The downside is that when you run bulk-smushing again, Smush will need to re-smush all the images but it should also deal with those re-created, previously missing thumbnails.

    If regenerating thumbnails doesn't help, I'm afraid you'll need to actually re-upload images to the site via Media Library - just like my colleague Predrag suggested previously - and then run bulk smushing again.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.