there...I have a few sites where I'm testing out

Hey there...I have a few sites where I'm testing out the Snapshot plugin. On some of them they are running fine and are syncing to Dropbox but not syncing from Dropbox to my local machine. All other files do except yours.

Also, on some sites it's not running at all or the ones that are running have the date as 1969. Very inconsistent backups which is not something I want to risk. Any thoughts?

  • Vinod Dalvi

    Hi @jason_cyr,

    Thanks for posting on the forums and sorry to hear of the problems you are having.

    This will certainly take a bit of trial and error to try to figure it out.

    Therefore in an effort of expediency I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advise for us.

    I have notified the plugin developer to reply here.

    Cheers,
    Vinod Dalvi

  • Paul

    Hey @jason_cyr,

    Two things/questions I see from your post. I'll try and provide feedback to each below.

    On some of them they are running fine and are syncing to Dropbox but not syncing from Dropbox to my local machine. All other files do except yours.

    Well not sure how to answer that. How are you syncing to your local machine? Or should ask what is your local machine? I'm on Mac (OSX) and have the Dropbox app running and I have snapshot running on over a dozen sites with daily backups. I can see all of them via my local system. Though I'm not doing file syncing with Snapshot but creating individual .zip archive.

    Are you checking the correct place? Because of the way Snapshot is written it is in 'sandbox' mode. This is means the files are sent from your server to the Apps/WPMU DEV Snapshot/ directory. Have you tried going to the Dropbox web page and verify the files are in fact there?

    on some sites it's not running at all or the ones that are running have the date as 1969. Very inconsistent backups which is not something I want to risk

    I'm not sure what date you are referring to. This could be just inconsistencies with your hosts. Basically Snapshot relies on the WordPress scheduling system (WP_Cron) to call the snapshot function at certain specified intervals to initiate the backups. The WP_Cron system needs front-end traffic to reliably keep itself primed. so if you are setting the daily snapshot backup time at 2am when you have very little or no traffic that would be your issue.

    On the other hand have you tried manually running a snapshot on those off sites to verify this is not a memory related issue. Maybe you can post back and we can walk through some specific issues.

  • jason_cyr

    Hey man...yeah, the weird thing is that if I go to Dropbox.com they folder and files exist under /apps. I have checked my sync settings and they simply are not syncing with my local machines. The only folder not doing so...very strange.

    I also have all of my backups set to Archive but on some sites that have been connected to Dropbox, the files are not showing up or the backups are not running as scheduled. Very frustrating.

  • Paul

    @jason_cyr,

    Hey man...yeah, the weird thing is that if I go to Dropbox.com they folder and files exist under /apps. I have checked my sync settings and they simply are not syncing with my local machines. The only folder not doing so...very strange.

    Let me try and understand. The snapshot archive are making it from your server(s) to the Dropbox Apps folder. Then sadly that is as far as we can help. If I understand the second part of your statement above they files are not syncing from Dropbox App folder to your local system. Correct? Afraid that might be something you take up with Dropbox or the app itself. There is nothing in Snapshots use of Dropbox that would prevent it from having the files sync. Do you have other app folders not form snapshot which are syncing?

    I also have all of my backups set to Archive but on some sites that have been connected to Dropbox, the files are not showing up or the backups are not running as scheduled. Very frustrating.

    IF the backups are not running this generally means you are not seeing enough front-end traffic to kick off the WordPress scheduler (WP_Cron). Basically snapshot registers a function to be called at a certain interval with WP_Cron. So if the function is not being called then that is your issue. Do the archive run correctly manually? Do they run when you click the 'run now' option on the All Snapshots listing?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.