There's a weird bug in my site. The full versions

Hi guys

There's a weird bug in my site. The full versions of the masterclass podcasts won't play on the Masterclass page (you have to be logged in as a subscriber to see it) but I CAN play them when I edit the page in the WP dash. This page is handled by the Membership 2 plugin too as it's for subscribers only.

Can you help?

e

  • Sajid
    • DEV MAN’s Sidekick

    Hi Emma Clarke,
    hope you are doing good today :slight_smile:

    What pod cast service you are using or its a self hosted audio files ? Also could you please post the link of that page here so I can take a look. Make sure you the support staff access active so we can login and take a closer look.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Emma Clarke,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access and providing more details about the issue.

    I could login and figured that when the media protection add-on is enabled, the embedded .mp3 file does not work with any protection method.

    But, neither myself or my colleague Nastia could reproduce this issue on our testing environments. With or without SSL certificate.

    While trying to play the media, I am getting following error in JS console of the browser.

    mediaelement-and-player.min.js?ver=2.18.1:27 GET https://www.hushhushvoiceovers.com/downloads/?ms_file=ms_4420.mp3?_=7 (anonymous function) @ mediaelement-and-player.min.js?ver=2.18.1:27n.event.dispatch @ jquery.js?ver=1.12.3:3r.handle @ jquery.js?ver=1.12.3:3
    undefined:1 Uncaught (in promise) DOMException: Failed to load because no supported source was found.

    That means something on your website or even server configuration messing with the media protection add-on.

    We will start from plugins and theme conflict here to find the culprit. You can run a plugin/theme conflict on your website as described in our getting support manual (flowchart). I avoided to do this on your website without your permission. Please do that and let me know how it goes so we can move forward.

    Look forward towards your response e :slight_smile:
    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Emma Clarke,
    Hope you are doing good today :slight_smile:

    Thanks for the go, I made a plugin/theme conflict on your website (restore it back to original afterwards) but could not find a culprit. It means there is issue on your server that is not capable of handling the protected media files.

    Please send in the FTP (to browse the directory and edit files) and WordPress admin login (skip if you keep the support staff access active) details via our private contact form in following format so I can check the files and .htaccess file.

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls
    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :simple_smile:
    https://premium.wpmudev.org/contact/

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Emma Clarke,
    Hope you are doing good today :slight_smile:

    Thanks for sending in details of your website. I have enabled the debugging and tried to find any thing in .htaccess file that could cause the issue but could not find the clue except following error message while access the file directly.
    https://www.hushhushvoiceovers.com/downloads/?ms_file=ms_4420.mp3?_=7 Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCH

    Upon further research I found the ticket on stackoverflow that states NGINX configuration and file permission. I tried to change the file permission of folder from 755 to 777 and file from 644 to 777 but that did not made any difference.

    Did you added any code in NGINX configuration file ? I can see you have installed Hummingbird or Defender plugin that requires some addition in NGINX configuration file.

    Please let me know so we can move forward :slight_smile:
    Cheers, Sajid

  • Emma Clarke
    • Site Builder, Child of Zeus

    Hi Sajid

    Thanks so much for taking a look at this for me. I haven't personally changed any code in the NGINX file - I doubt my colleague did either! If you can let me know how this can be fixed, I'd be very grateful.

    Thanks!

    Emma

  • Sajid
    • DEV MAN’s Sidekick

    Hi Emma Clarke,
    Hope you are doing good today :slight_smile:

    Thanks for your feedback Emma Clarke, it will help towards fixing this issue. Your server is unable to handle the request with encrypted media file URL. I have never seen this issue before with any other member or even on my own website.

    I am flagging developer of this plugin for his invaluable feedback on this matter. Either myself or developer post back a reply here as soon as possible.

    Meanwhile, I hear from the developer, would you let me know what is your hosting provider ?

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.