This Community forum feature has a length bug on question/titles.

This Community forum support area has a bug. The "Ask A Question" title input field allows 13 characters more than it can display on the resulting pages that show the title, in case nobody had noticed. :slight_smile:

Cheers!

  • aristath
    • Recruit

    Hello again @markweb,

    We used to have a lot of issues with users not entering titles, entering really short meaningless titles, or even entering the body of their message as a title. All of the above are really bad for SEO.
    That's why we tweaked this a little and now it works that way.
    It's not a bug.... :slight_smile:

    Cheers,
    Ari.

  • markweb
    • WPMU DEV Initiate

    Makes sense, but just to be clear, the problem wasn't that you have a separate title/question field, but that it accepts more characters than you ever display. For example, in another thread, I entered a title of:

    "Is there a way to show the post date & 'Read More' link with the Recent Global Posts Widget plugin?"

    But it only shows up as:

    "Is there a way to show the post date & 'Read More' link with the Recent Global Posts W"

    I would think that that would be worse for SEO than showing the entire title, and certainly not as elegant or useful when looking for topics. :slight_smile:

    I hope that makes more sense.

    I can't help but wonder if my use of an &mpersand and single 's made the field run over, because your email notification doesn't decode special characters, using a subject in this case of:

    "Is there a way to show the post date & 'Read More' link with the Recent Global Posts W"

    That might explain why the field output is turning up short. :wink:

    Cheers,

    -Mark

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.