This is for SlideIn Developer – @Vladislav

Hi @vladislav,

Please see link of theme: http://www.milliondollarpractice.net/?attachment_id=3852 as per discuss on this ticket: https://premium.wpmudev.org/forums/topic/slidein-not-showing-on-homepage#post-399627

Thanks,

David

  • Vladislav
    • Dead Eye Dev

    Hello,

    I actually thought you’ll send the link via our contact form, but this works too :slight_smile: Thank you very much for this, checking the plugin in combination with the theme cleared any possible misunderstanding right up! I was, of course, able to recreate the conflict you experienced on the home page too, and also to determine why it happened – the home page for your theme has mostly static content (no loop), so the plugin didn’t have anything to grasp to in order to inject the markup it needed.

    There is a solution for this problem in the latest plugin release (v1.1.1, just released). In order to get the slide-ins to show up nicely on your home page too, please go to the plugin settings and, under the “Advanced” section you will see a new field labeled “Custom injection hook”. Please, delete the default value from this field and put this there: “wp_footer” (without quotes and any surrounding spaces – please note that the casing is significant too). This will tell the plugin to use a different hook to inject the markup it needs for the slide-in to appear. Once you save your settings, the slide-in should normally appear on your home page too.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.