This looks to be a great plugin. When will it be working

This looks to be a great plugin. When will it be working for the 3.6 betas?

When I install it, I get an "error" on the install button. It is in the plugins directory when I log into my server and check it. When I go to the plugins page of my site, I get an error 500. I then delete the popup directory and all is well. I assume it has something to do with the fact that I am running 3.6 beta.