"This page can't load Google Maps Correctly" Error

We have a website at amherstridge.com that makes use of the Google Maps API Plugin. However when any user accesses the page they see a message stating "This page can't load Google Maps Correctly." The console within Chrome DevTools then shows three potential issues.

1. Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

2. Google Maps JavaScript API warning: InvalidVersion https://developers.google.com/maps/documentation/javascript/error-messages#invalid-version

3. Google Maps JavaScript API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required

However, we have already tried upgrading the Google Maps API Plugin to the latest version, and we have put in a freshly generated (from yesterday) Google Maps API Key. We are therefore not sure why the maps still are returning the errors.