This plugin seems not to be working for me. i have followed

Hello,

This plugin seems not to be working for me. i have followed the instructions and tried a permalink reset. i have also tried adding admins / subscribers to have different access levels. everytime i save it and change to the other it has deleted!

trying to access this page:
http://xemme.com/questions

Im wanting to have all the questions listed there and then the logged in users can click on it. just like in the screenshots on your website but using my themes style.

Cheers
James

  • Vinod Dalvi

    Hi James,

    I hope you are well today and thanks for posting on the forum.

    I checked the questions page on your site http://xemme.com/questions/ and found the question is listing on it as displayed in the attached screenshot.

    Don't all questions you have created list on the questions page?

    everytime i save it and change to the other it has deleted!

    What have you saved and what other deleted?

    Could you please explain your question a bit more in detail so that i can help you to resolve it?

    Kind Regards,
    Vinod Dalvi

  • james

    thats great ... but for some reason i stall cannot see that!

    is there a reason for that?

    also how did you see that as i did not see you register on the site ? (this will help me as im trying to lock it all down using your membership plugin!)

    what i was saying was in the area where you pick who can see what in the Q/A settings. when i tick all the boxes for a user role and then save it, it does not seem to keep the settings, as when i switch to another user role to edit and then go back to it, all the tick boxes have been unticked.

    Does that make sense?

    Cheers

  • Vinod Dalvi

    Hi James,

    Thank you for your reply.

    thats great ... but for some reason i stall cannot see that!

    is there a reason for that?

    This can be a cache issue as i think you are using a W3 Total Cache plugin.

    Could you please try clearing cache or temporary deactivating this plugin?

    also how did you see that as i did not see you register on the site ? (this will help me as im trying to lock it all down using your membership plugin!)

    I didn't register on your site but i can see the questions. I think this is because you have granted "View questions" capability to QA Visitor role on the following path.

    Admin Area -> Questions -> Settings -> Accessibility Settings -> Assign Capabilities

    what i was saying was in the area where you pick who can see what in the Q/A settings. when i tick all the boxes for a user role and then save it, it does not seem to keep the settings, as when i switch to another user role to edit and then go back to it, all the tick boxes have been unticked.

    I have tested it on my test site using latest version of Q&A plugin and found it's working fine.

    Just make sure you are saving the settings after checking the checkboxes before switching to another user.

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi James,

    Thank you for granting me support staff access.

    I could reproduce the issue on your site that the questions on the questions page http://xemme.com/questions/ were not displaying for logged in users.

    I resolved the issue by clearing the cache from "SG CachePress" plugin and assigned the capabilities for Administrator role on the following path which were not assigned as displayed in the attached screenshot.

    Admin Area -> Questions -> Settings -> Accessibility Settings -> Assign Capabilities

    Could you please check it and let me know whether it works for you or not?

    Please advise if you have more questions.

    Best Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.