"This site can’t be reached" error when creating new sites on multisite

I followed the Guide for setting up a Multisite network, and it all seemed to be going smoothly.

However, when I create a new site on the network, that new site isn't accessible at all. I can't see the dashboard or the site - I just get a "This site can't be reached" page with the "err_name_not_resolved" error. Obviously, it can't locate the new site...

I've poured over the support forums for answers. I've checked and double checked my .htaccess and wp-config files to make sure they include the required code (they do as far as I can tell - I copied it directly from the Network Setup page). I do have the wildcard subdomain setup. The A record for the wildcard also points to the correct IP address.

I'm really stumped, and feeling like trying to go multisite was a bad decision. I do think it will be better in the long run, but right now I'm definitely overwhelmed. I tried deleting the subdomains and trying again. But nothing changed. HELP!? :slight_smile:

Other info:
Hostgator reseller server
PHP 7.0
Wordpress 4.9.8

I've opened support access, and I can provide code and admin info in another post(s).

Thanks.

  • Raylene

    Full wp-config code (minus the database password, and auth keys):

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'beweird_wrdp1');
    
    /** MySQL database username */
    define('DB_USER', 'beweird_wrdp1');
    
    /** MySQL database password */
    define('DB_PASSWORD', '');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '');
    define('SECURE_AUTH_KEY',  '');
    define('LOGGED_IN_KEY',    '');
    define('NONCE_KEY',        '');
    define('AUTH_SALT',        '');
    define('SECURE_AUTH_SALT', '');
    define('LOGGED_IN_SALT',   '');
    define('NONCE_SALT',       '');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    define( 'WP_ALLOW_MULTISITE', true );
    define('SUNRISE', 'on');
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'itsoktobeweird.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
  • Raylene

    Full .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress
  • Adam Czajczyk

    Hello Raylene,

    I hope you're well today and thank you for your question!

    The wp-config.php and .htaccess seem fine. I have accessed the site assigned to this ticket and it's working fine for me. I was able to access the sub-site there (suburban...) and its dashboard.

    If you didn't make any changes meanwhile to solve that, I would say that most likely it was DNS related - it takes time for DNS settings to be propagated across the web so after any changes are made, it's usually necessary to wait (sometimes even as long as up to 24-72 hours!).

    Can you confirm that you can now access sub-site?

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.