Thumbnail resizing breaks on certain pages

Hey there,

On my homepage,, you can see that the featured thumbnail gets displayed a few different ways. However, it doesn't show up correctly in a few locations.

If one looks at a story on the homepage, the thumbnail appears properly shrunken and cropped. However, if one were to click on any category from the top menu (Movies for instance), the list repopulates and the exact same story will show up in the same exact styling, except now the thumbnail is mis-sized. It still appears cropped behind the thumbnail cell window, but it is clearly loading a full-size version of the image rather than the thumbnail.

Another instance of this happening can be seen by returning to the front page, but in the right sidebar, seeing the "Must Read" column. In that list all the thumbnails are showing up as Full Size images, behind that cell window.

Any ideas?

  • Adam Czajczyk

    Hey Filup,

    I hope you're having a nice day!

    I've visited your site and I can confirm that issue. It seems like the listing on a home page is picking "Featured Image" as set up for particular post, which is fine. On category archive pages though (and for "Must Read" column) it seems to be using the first image from post content as featured.

    That said, I've examined
    - image properties
    - theme settings
    - theme template and functions files

    of your site and it looks like the theme is using custom function do display those thumbnails. I wasn't able to dig that deep directly through the dashboard but I'm assuming that these function works by default picks up a "Featured image" and if it's not available or disabled it is searching for the first image inside content.

    I think then you may want to go to your dashboard's

    "Appearance" -> "Customize" page -> "Post/Content settings" tab

    and un-check the "Hide feature image" option. This should make featured images available again, therefore be displayed properly. The side-effect would be that it will also display additional image over post/page title on single post/page view. This however could be hidden with a simple CSS rule.

    The drawback here is that I tried to do this but it seems that WP Engine's CDN and/or its cache is preventing me from seeing any changes. That said, I think that after applying the change I described above you could then access your server's settings and there should be an option to clear or disable cache. It may also take a while for CDN to update its contents.

    Give this a try please and let me know it those changes work for you and I'll be then glad to assist you with CSS to hide those additional images on post/page single view.

    Kind regards,

  • Filup

    I'm not sure about that delay, because in my working with the site I find that it seems like certain changes have no effect on the site. Almost like there is alternate CSS somewhere else that is overriding the changes.

    I unchecked the "Hide feature image" option, but have seen no changes. I'll leave it that way for 24 hours or so to see if it eventually takes effect, but if I don't see a change, I'll check it off again tomorrow.

  • Predrag Dubajic

    Hi Filup,

    WP Engine has some strong caching which is probably why you don't see the changes right away.

    Looking at your site I think that either the theme doesn't create required thumbnail for the category page or if is than the category page is not using correct thumbnail.

    Could you zip your theme and upload it to any file sharing service and then send me the download link via our contact form so I can check category page template?

    You can send me the link using our contact form and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"

    - Download link
    - link back to this thread for reference
    - any other relevant urls

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.