Thumbnails not displaying in home page

Hello -

I am new to the forum and also new to working with wordpress/PHP. The network theme is really a nice looking theme and I'm looking to use it in my home page. I've been having some problems getting the thumbnail images to show up in the main page. Here are my questions:
1. Would images on the blog posts automatically be taken as a thumbnail in the front page? If not, how do I set the images for the blogs on the front page?
2. Is there an easy way to display recent blog posts across all blog sites in the network via configuration? What do I have to do to accomplish this?
3. Is there a way to put another section on the front page for most commented posts across the network?

Thanks in advance for your help!

  • DavidM

    Hi John,

    First off, WPMU DEV! Glad to have ya here!

    1. Would images on the blog posts automatically be taken as a thumbnail in the front page? If not, how do I set the images for the blogs on the front page?

    The images are the featured images in the respective posts. Here's a quick video walkthrough of that in case you're not quite familiar.
    https://premium.wpmudev.org/project/featured-image

    2. Is there an easy way to display recent blog posts across all blog sites in the network via configuration? What do I have to do to accomplish this?

    Yes actually. Assuming you've already got Multisite setup, you simply need to configure the options at Network Theme > Advanced Options. Selecting the "Network Posts" option as illustrated here should do the trick!

    3. Is there a way to put another section on the front page for most commented posts across the network?

    That would actually require a fair degree of customization of the theme code, though if you're comfortable with that you could have a look at the multisite_recent_posts() function in the following:
    network/library/functions/custom-functions.php

    Hope that helps, let us know if you have any questions on that all!

    Thanks,
    David

  • John

    Hi David,

    Thanks for getting back to me. Initially the feature image section was not showing up. I did some googling around and found that I had to allow image uploads in the network settings.

    I think I didn't word my question #2 correctly. What I meant is that instead of having one most recent post per blog, I'd like to have the listing of all recent posts irrespective if they belong to a single blog. I don't think it is possible but worth asking the question.

    I'll take a look at your recommendation to look the PHP code.

    Thanks again!
    John

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.