Thumbnails not visible under the Media Library

I am having issues with images on my WP site. They appear to be uploading properly because I can open the image on the browser using the file URL but none of them has valid thumbnail visible and are not being smushed either.

I tried deactivating all plugins, completely all of them and I also changed the theme to a default theme and there was still an error.

I have WP sites on the same server even using the same template and they're fine. Same php settings too. So I don't think it's a server issue.

Any image I upload doesn't seem to work and I'm not sure if it's because the WP Smush settings.

  • Ash
    • WordPress Hacker

    Hello Josh

    It seems the issue is with WP Offload S3 Lite plugin. When I deactivated the plugin and uploaded an image, it worked fine. Then I reactivated the plugin and uploaded again, and it worked too.

    Maybe there was a setting, that was fixed by reactivating the plugin. It won't take any effect for existing images, you need to ask their support if there is any way to do that.

    As a side note, I was checking your wp-config.php file and found that you had placed DBI_AWS_ACCESS_KEY_ID and DBI_AWS_SECRET_ACCESS_KEY in wrong place. So, I moved those to the right place. That might be related too. (I think it is). So, please mention that when you contact the offload support team.

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash

  • Josh
    • WPMU DEV Initiate

    Hi Ash/all,

    Thank you! I had deactivated all plugins and reactivated them twice yesterday but I guess it just needed a magic touch!

    I also noticed WP was updated automatically overnight so maybe that helped too.

    HUGE thanks for your effort!
    Josh

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.