Tim Thumb image problems with MultiSite

I’m moving a single WordPress site into a MultiSite network and having a problem with the images. This is an archive on the single site (still up and running):

http://inchiequilts.com/category/daily/

And this is the same page on the network site:

http://inchiequilts.dreamweavers-quilts.com/category/daily/

The error presented when I right click on the images on the network site and choose “View image” is:

A TimThumb error has occured
The following error(s) occured:

Could not create the file cache directory.

Oddly enough, the main site on the network displays images just fine, and both sites are using child themes of the same theme framework. Here’s the main site on the network:

http://dreamweavers-quilts.com/

I’ve tried to figure out where the cache directory is supposed to be for the problem site and create it myself, but still no joy. Since the problem site is using a child theme just like the main site is, you’d think that the cache directory would be the same one, and since the main site is working, that the problem site would be working too, but it’s not obviously.

In the past, I’ve had to ask my host to set special ownership and permissions for cache and upload directories for them to be functional for WordPress, and this may be necessary for this problem as well, but I’d like to make sure that I’ve not set something up incorrectly before I trouble them with this, and also, I don’t know which directory to tell them to set permissions and ownership on at this point.

If a WP expert could have a look and help me out, I’d appreciate it!

  • Raevenne
    • Design Lord, Child of Thor

    Thanks for the reply Jack.

    Here’s the line that sets the cache directory:

    if(! defined('FILE_CACHE_DIRECTORY') ) define ('FILE_CACHE_DIRECTORY', '../cache');

    The odd thing, like I said, is that the images are loading properly on the main network site, which uses the same theme framework as the problem site.

    I’ve actually found that post at stackoverflow while searching for a solution to this issue, but it didn’t help.

  • Raevenne
    • Design Lord, Child of Thor

    I did go ahead and contact my host to see if it was a permissions issue and they indicated that it wasn’t, but that there was some sort of redirect issue related to the .htaccess file. There’s nothing in the .htacces file except what WordPress says to put in there when you set up a MultiSite Network, so I’m a bit stumped by that answer.

    In the end, I just disabled the function to use TimThumb at all in my theme framework, made a change to the code that powers the box in the sidebar so that the images are resized by the default functions in WP instead of using TimThumb, and it’s all working fine now. Considering that TimThumb has had security issues in the past, this is probably a better option anyway.

    Thanks again for the reply, Jack. Consider this issue resolved. :slight_smile:

  • Jack Kitterhing
    • Code Norris

    Hi there @Raevenne

    I hope you are well today and thank you for letting me know it’s been resolved :slight_smile:

    Glad to hear it’s working, well glad to hear you found a workaround that works :slight_smile:

    Thank you for being a WPMU DEV member and have a great weekend!

    Kind Regards

    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.