Time available issues on Appointments+ 1.5.5 Beta

I would like the booking times available to be every 30 minutes even though I have a couple of 15 minutes service duration set among my services. Is that possible?
I am using the Duration add-on as suggested.

Our start time is set to 10:30 for every provider and it still shows 10:00 as unavailable. Is it possible to have it show the starting time properly to avoid confusion? The first rectangle should be 10:30.

Please help.

Thank you.

  • Luís

    Hi @more,

    I hope had been good today!

    Yes, it's possible, but you need to define in Appointments -> Settings -> General, the Time Base as 15 minutes.

    Our start time is set to 10:30 for every provider and it still shows 10:00 as unavailable. Is it possible to have it show the starting time properly to avoid confusion? The first rectangle should be 10:30.

    In Appointments -> Settings -> Working Hours, you need to select the Service Provider in the dropdown field "List for", and then define the start hour.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • more

    I am very angry because yesterday when we went to see why we did not get any appointments in the last 4 days, I realized that someone has removed all of my service providers and changed all the working days to "No" making the appointments page mute and useless.

    As I told you, I know about the drop down menu and all of my service providers were correctly set to start at 10:30.

    When I added 5 service providers and selected all the services for them the A+ plugin has stopped working. The page would never load. Just like the problem we have been dealing with for over a month.

    If it was you that removed my service providers or have changed our business hours, you should have notified me immediately because this is very irresponsible on your side.

    We lost a lot of business because of problems with your plugin and we are really losing patience.
    Jude is the one that worked on the website before and I respectfully request that you do not make any further changes to my site without notifying me.

    Thank you.

  • more

    Hello kasia, Luis

    Take a look at this thread first https://premium.wpmudev.org/forums/topic/urgent-appointments-page-is-not-working and you will understand the mess we are in because of your plugin. As I said, when the plugin stopped working I disabled it because of the resources issue we have every time the plugin stops working. And before you start about the resources, We have switched to a VPS with SSD's and the whole lot because of this plugin, which is still very messed up. Jude was able to write some code in the beta version that finally got it to work, but the time issue was still there, GCAL did not work and the description issue is still there too. She then instructed me to start separate threads for these issues. I think it was wrong and it only added more headache and frustration such as the situation we find ourselves in now. Someone deleted my service providers and changed all week days to "no", as in "not working"

    When I tried to add the service providers the plugin died again. That is why I deactivated it.
    Please have Jude look at this again.

    Thank you.

  • more

    Hello Kasia, Luis, Jude

    I am trying to set the plugin up again. The time rectangles are still showing 10:00 and 10:15 even though all service providers including the base start at 10:30. Why do we need to have these there to confuse the users. We open at 10:30. Should be pretty simple.
    In fact I would like to have rectangles for every 30 minutes and not every 15 minutes, even though I have several service duration set to 15 and 45 minutes. Already using the Duration add-on.

    The entire website becomes very slow when A+ is activated.
    Please help.
    Thank you.

  • more

    Hello Kasia,

    I had 1.5.5 installed until several minutes ago. Downloaded it off your website and uploaded via FTP ysteday. I just finished uploading 1.5.5.1 right now and would like you to take a look at the time issue and also the fact that the plugin is slowing down the entire site and causing so many issues. I have really gone to basics with the plugins, tried to remove almost everything. Even plugins I would have liked to use, only so we can have Appointments+ working on a healthy website.

    I have enabled the WPMU plugin and granted you access. Please be careful and let me know what you find out. The appointments page I have created for testing is at http://www.glitteratinaillounge.com/make-an-appointment-new/.

    Thank you.

  • more

    Please add @jude, @quarla and @luis to this discussion. The host developers have run tests on the site to help me find the problem at my request.

    Please read the test results they sent me moments ago:

    I was able to narrow down 2 active plugins that are setting no-cache
    headers on your site. The first one is "appointments" which I temporarily
    disabled to test the site. Then noticed the site was no longer setting
    the no-cache headers. I went ahead and re-enabled it for you after the
    tests, since it appears to be part of your site. So with this plugin
    depending on what it does, you might be able to contact the developer to
    see if there are anyways to modify the no-cache headers if they are not
    necessarily needed. Using the grep command below I was able to find
    reference to the no-cache headers. I placed this below;

    glitteratinaillounge.com/wp-content/plugins$ grep -R Cache-Control .

    ./appointments/includes/class-app-ajax.php:
    header('Cache-Control: must-revalidate, post-check=0, pre-check=0');
    ./appointments/includes/external/google/Http/Request.php:
    $rawCacheControl = $this->getResponseHeader('cache-control');

    You can continue to use the plugin but your site won't be able to take
    advantage of the Varnish caching as it should. So you may continue to see
    increases in resource consumption as you have been lately.

    The second plugin found is "wordfence" which uses cookies on every page
    load. However with this plugin there should be an option to disable that
    from the plugin set up in the dashboard.

    The SEO plugin had no affect on Varnish, so that one is okay. I did go
    ahead and leave all three plugins enabled for you since at the moment
    they are not causing issues. However you might want to look into the
    "appointments" plugin to see if that can be modified to stop leaving the
    no-cache headers.

    I hope this investigation provides some further insight for you to
    continue troubleshooting your site performance. If you have any further
    questions or concerns, don't hesitate to include this in your reply.

    Regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.