Time slot does not work for all services

As a podiatrist I offer 13 different services (see picture).
The time during the service is different, the smallest is 10min and the largest service is 50min.

The basetime is 10 minutes.

When I test the agenda. it works fine for the first service of 40min. Times where already an appointment is in Google calander, are blocked well. For example 31 okt: pnly 12.40 is still free to have an appointment, the rest of the day is not possible.

But when I try another service for example 20min, then the whole day is available, which is strange because only 12.40 is still available.

What is going wrong here?

  • Vaughan
    • Support/SLS MockingJay

    Hi Linda,

    Hope you're well?

    That seems strange, the only possible reason I can suggest for that is if that particular service has been assigned to a different service provider.

    Can you doublecheck the service providers and see if any are different?

    Hope this helps

  • pxwm
    • WP Core Meltdown

    Hi @Vaughan - I hope you don't mind me chiming in

    Hi @Linda

    I've checked your screenshots and I would suggest the problem may be due to the 'capacity' setting for each 'Service'
    Could you try changing the 'capacity' value from '1' to '0' for each 'Service' and hopefully this will resolve your problem.

    You also mention that you have set the 'Time Base' value to 10 mins.
    Just to make you aware that the A+ default settings do not use the 'Time Base' setting and instead use the 'duration' setting for each 'Service'.

    e.g. If your 'Service' has the duration set as 20mins then if you select this then the schedule will display time slots every 20 mins.

    If you wish to have 10 min time slots available for all your 'Services' then please try the following:-

    Login to your Wordpress dashboard as Admin.
    Then select 'Appointments' then 'Settings' then the 'Add-ons' tab
    Then scroll down to the 'Durations' Add-on and Activate
    Then select the 'General' tab and in the 'Time settings' section you will notice that there are now some new fields.
    Locate the 'Time slot calculus method' field and choose the 'Minimum time based appointment duration calculus (legacy)' option
    Then Save

    This should now display 10min time intervals in your schedule.

    I hope this helps
    Regards
    SteveB

  • Linda
    • Design Lord, Child of Thor

    Hi @SteveB,

    Thank you for your help! I've choosen the option Calculation based on services, I think that works good for me, it shows beter time slots so I will not have spare minutes left.

    Still have the problem that only the first service shows my calander right, the other services looks like they are not synchronised with my Google calender. Still don't understand how that is possible.. It looks like I don't have appointments for the day but in my google calander are allready appointsments.

    Hope u can help,

    Regards,

    Linda

  • Linda
    • Design Lord, Child of Thor

    Hi,

    I've tried everything and checked everything, I can not find why it happens that onlyn the first service synchronises well and the other services won't let see the right available space in my agenda.

    I hope someone can help, I really would like to integrate the plugin on my site a.s.a.p.

    Best regards,

    Linda

  • Vaughan
    • Support/SLS MockingJay

    Hi Linda,

    Sorry for the delay, I actually don't usually work weekends. Thanks @pxwm too for the suggestion, good to see you around again Steve :slight_smile:

    @Linda it looks like the support access has expired, if you could regrant it again.

    Just to check though, in your gcal settings, have you clicked for service providers to share calendars? See screenshot.

    Thanks

  • Linda
    • Design Lord, Child of Thor

    I've cheked everything in Google calander, but the problem is still there.
    I can't figure out how this happens. I'm trying to let it work for two weeks now :slight_frown: Hope someone can help!

    Best regards,

    Linda

  • calvinrogercanas
    • New Recruit

    Hello Linda,

    I hope you are well.

    I checked your site and checked also the api settings of G-Calendar. It is showing that the api settings is indeed correct but would you mind if we re-integrate the Calendar API to your site? I want to try this out hoping that this method will solve your issue.

    Best regards,

    Calvin

  • Patrick
    • Support Monkey

    Hi @Linda

    I just replied to the new thread you created for this issue with the solution as follows:

    If you are the only service provider, please ensure that no service provider has been set.

    Then, when a time is reserved by Gcal, it will block off the corresponding time for all services on your make-an-appointment page.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.