Time slots not showing correctly and other issues

I have put in a work day of 10am - 5pm, and a break of an hour from 1-2pm, but the break is showing at 4pm instead? What am I doing wrong?

How do I remove the Show available times button, it doesn't seem to do anything?
http://russellcheek.thedesignweb.com.au/?page_id=612

I have set auto confirm to NO, but I am still getting the auto confirm button at the bottom, and I have set Send Confirmation and Notification both to yes, but no emails are being sent.

Thanks for your help.

Belinda

  • faydra_deon

    Hello, @belinda_johnstone:

    As for the times, do you have the time in Settings the way it should be for your timezone?

    Also, some plugins prefer you not use the UTC-values, but they want you to pick a city name near you, if not the city you're in.

    As for "Show Available Times," that may be a shortcode that you didn't remove or that you added by mistake. You're right. I clicked it and nothing happened.

    As for confirmation, you're not going to get any emails until the appointment has been confirmed.

    If you're getting a button asking you to confirm the appointment, then there's something that's not set to yes and/or no.

    I set this up two days ago for a client, and I had to go back through and read those descriptions, like, three times, but I thought they were saying one thing when they were saying something else. They were a bit confusing for me.

    If only some or none of this gets you where you need to go, then I'm sure a staff member will be along soon to get you squared away.

    Faydra...

  • Jack Kitterhing

    Hi there Belinda,

    I hope you are well today and thanks for your questions.

    On your appointment page, if you edit it, you should see some shortcodes, can you provide a list of the shortcodes you have on there please :slight_smile:

    The confirmation email won't be sent until the appointment is confirmed like
    @faydra_deon said, though if you have it set to send you a notification of a pending appointment is that also not working?

    If that's the case. do you receive emails from your site, such as password reset emails for example.

    Thank you!

    Kind Regards
    Jack.

  • belinda_johnstone

    Hi and thanks for your reply Faydra!

    I am using Sydney as my timezone.

    I checked the shortcodes, but thought I had them correct.

    The booking is showing as confirmed straight away, so I thought it would send the emails, but it didn't. I don't mind if they are pending and then an email goes out. There is no payment required though.

    Yes, I've been reading and re-reading, getting there slowly, but then got a bit stuck.

    Hi Jack,

    Thanks for your prompt reply...

    Here is the shortcode on my page:

    [app_services ... select="Please select a session type:"]
    [app_monthly_schedule]
    [app_pagination month="1"]
    [app_login]
    [app_confirmation ... title="Please check the appointment details below and confirm:"]

    I have also included some screen shots.

    Yesterday I had set just a 180 minute session time, which set the times to 10am and 1pm, although I thought it would be 2pm with the 1 hour breaktime, but I've changed the time blocks to 60mins - I thought the time blocks next to the calendar might look different but they stayed at 10 and 1??

    Thanks so much for your help,

    Belinda

  • pxwm

    Hi @elinda_johnstone

    You can remove the 'Show available times' button by adding the following parameter to your app_services and app_service_provider shortcodes:-

    autorefresh="1"

    e.g.

    [app_services autorefresh="1"]
    [app_service_providers autorefresh="1"]

    I've also noticed that in the shortcodes you have posted:-

    [app_services ... select="Please select a session type:"]

    Suggest it would be best to remove the dots so:-

    [app_services select="Please select a session type:"]

    Then add your parameter:-

    [app_services autorefresh="1" select="Please select a session type:"]

    This should remove the 'Show Available times' button and will autorefresh the page when a Service or Service Provider is selected form the dropdown

    I've also noticed in the list of shortcodes you posted you don't appear to have a shortcode for the Service Provider dropdown

    [app_service_providers autorefresh="1"]

    As for your break time problem.
    Could you please confirm if you book an appointment does it capture the correct time or is this also out by 3hrs?

    I hope this helps
    Regards
    SteveB

  • belinda_johnstone

    Hi Guys, thanks again for all your help.

    Yes, the correct time is being booked and captured.

    SteveB, your suggestion worked when I added [app_service_providers autorefresh="1"] then 'SHOW AVAILABLE TIMES' was removed.
    Since I have only one service provider I wanted to leave this out, but maybe I can just use display: none.

    So down to just the time and break time issue. Can you see any setting I may have wrong that could be moving the break time to 4pm?

    Thanks,
    Belinda

  • pxwm

    Hi @belinda_johnstone

    I'm pleased the solution worked.

    I've checked your Working Hours and could you carry out the following:-

    For the 'Service Provider' (Russell Cheek) you have a Multiple Break time with the 2nd one showing the 'Break?' field set to 'No' and the time set to 12h00 p.m. to 12h00 p.m.

    Could you revise the time from 12h00 a.m. to 01h00 a.m. and keep the 'Break?' field set to 'No'.
    The reason is that there is currently a bug in v1.3.1 that will still block out the time when Multiple Breaks have been set even if the 'Break?' field is set to 'No'. The developer is investigating.

    Could you also post the 'Working Hours' tab with the dropdown select for the 'no specific provider'.

    The reason I would like to review the 'Working Hours' for the 'no specific provider' is because you have stated that you don't have a Service Provider created and assigned to the single Service and I suspect that when you select the Service it is selecting the 'no specific provider' and if it is it will be using the 'Working Hours' set for the 'no specific provider'.

    Regards
    SteveB

  • pxwm

    Hi @belinda_johnstone

    To confirm you you can't remove a Multiple Break once added and this would not normally be a problem as you can just set the 'Break?' field to 'No' but due to the bug you have to set the start and end of the Break Time outside of the working hours.
    I've checked your latest settings and this looks fine.

    However as you state you only have one Service provider then this is fine but this means that you have to have the 'Working Hours' for the 'no specific provider' set up correctly.

    Could you also post the 'Working Hours' tab with the dropdown select for the 'no specific provider' so I can check.

    Regards
    SteveB

  • pxwm

    Hi @belinda_johnstone

    Can you please try the following:-

    Select the A+ 'Working Hours' for the 'no specific provider'
    Set all the 'Work? fields to 'No'
    Then Save
    Then select the 'test provider' and set all their 'Work?' fields to 'No'.
    Then Save
    Just leaving the 'Working Hours' set for the Service Provider called Russell Cheek.
    Then Save

    Then Select the 'Service providers' tab and create the Service Provider called 'Russell Cheek' and assign them to the Services.
    Then Save

    Then Select the Appointments page and add the shortcode

    [app_service_providers autorefresh="1"]

    directly under the shortcode

    [app_services autorefresh="1"]

    Then update the page

    Then Select the 'Add-ons' tab
    Then Activate the 'Durations' Add-on
    Then Select the 'General'' tab
    In the 'Time Settings' section you should now see a new field called 'Time slot calculus method'
    Select the radial button for 'Minimum time based appointment duration calculus (legacy)'
    Then set the 'Time period' field to 60mins
    Then Save

    Could you please test to see if this resolves the problem

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.