Times showing that are not possible on my calendar.

Since the last update, the CSS code given to me by your support team to not-show-times-that-are-not-possible has stopped working and I have too many time slots displaying.
The code looks like this and is placed in the "Additional css code" section:
.entry-content td{border:none;width:50%}
.app_timetable .notpossible {display: none !important;}

  • Nithin
    • Support Wizard

    Hey brightfuture333,

    Hope you are doing good today. :slight_smile:

    I suppose this is how you want the Calendar to look:

    If yes, I have already added the following CSS in the Additional CSS section, and now your site works fine.

    div.busy {
     	display: none;
     }

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • apurba_podder
    • Site Builder, Child of Zeus

    Hey brightfuture333,

    Thanks for asking. I have gone through your website & seen that not possible time slots are not showing. Display none property already applied on .notpossible div & it is working properly.

    Hope your problem has been solved. Please contact us if you need further assistance. take care.

    Kind regards
    Apurba

  • brightfuture333
    • Site Builder, Child of Zeus

    Hi Apurba,
    Thank you for your assistance.
    I might not have been clear about what I'm looking for. I DO want "busy" times to show (as the light color configured), but DON'T want "not possible" times to show.
    Is that possible?
    It used to work this way.
    Thanks much.

  • apurba_podder
    • Site Builder, Child of Zeus

    Hey brightfuture333,

    I have disabled the code given by nithin . For checking I have changed busy color. Now all the busy and free time slot are showing & all the not possible time slot are hidden.


    I think this is what you want to do. One more thing I have noticed that busy & not possible color code are same. You may use different color code for each slot.

    Kind regards,
    Apurba

  • brightfuture333
    • Site Builder, Child of Zeus

    Maybe I'm mixed up... so sorry for the going back and forth.
    My work hours are scheduled from 1:00pm to 6:00pm.
    I don't want anything before 1:00 showing... I thought that was "not possible".
    I thought "busy" would be times that have been scheduled within my work hours and those I do want to show as a different color.
    So, to clarify, if, say, I have someone scheduled for a full session at 1:00pm ( which allots 1.25 hours because padding doesn't seem to work either :slight_frown: ), then I want 1:00, 1:15, 1:30, 1:45, 2:00 to show up as light blue, and then 2:15 - 5:45 to show up as purple.
    Hope you can help me with this... it is very much appreciated!

  • Rupok
    • Support Ninja

    Hi brightfuture333,

    I don't want anything before 1:00 showing

    By default, any timeslot before the Providers starting hour is not shown in Appointment calendar. Please check the attached screenshot for reference.

    But on your site, hours are showing from 8AM, I'm not sure why. I've exported your appointment settings and imported in my local test site, still on my test site, the timeslots start showing from PM.

    I guess something on your site is causing this. To make sure no specific configuration in Appointment Settings are causing, we need to do some tests on your site. These tests might include changing your working hours, provider hours etc. But as this is a live site (I assume), I'm not sure if it's safe to do those tests on your site. Can we do those tests on your site?

    If no, then can you please create a clone of your site using our Snapshot Managed Backup and then restore that backup on another instance where we can do these tests, find the solution and then deploy on your live site?

    Please let us know. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • brightfuture333
    • Site Builder, Child of Zeus

    Hi Rupok,
    Your reply gave me an idea and I did my own test...
    The provider "Sundi - off hours" has times that start at 8am.
    When I changed those to 1pm, only hours starting at 1pm were displayed.
    So, your thoughts about settings were correct, but if a service is selected that is tied to "Sundi", then the display should reflect Sundi's hours, right?
    If a service is selected "Off hours session", then the hours tied to "Sundi off hours" should be displayed. Right?

    If you're making changes like this to test things, I don't mind you testing them. Let me know if it seems to work, otherwise, put them back??

    I really appreciate your assistance.

  • brightfuture333
    • Site Builder, Child of Zeus

    By the way, the way things are displayed now is actually perfect... I think what needs to be fixed then is just the way the display is set for each service... so when a service is tied to a certain provider show that person's working hours. If there is an overlap, say where a service is tied to 2 providers (not the case in my situation, but maybe someone else's), then show the earliest start time and latest end time. ??

    • brightfuture333
      • Site Builder, Child of Zeus

      Disregard last reply. I redid API credentials and appointments are now being added to my google calendar. I entered a test appointment and it also was sent to me acting as client with a different email address although as provider, I did not get an email. Not "that" important since I see the appointment in my calendar and the purchase. The email gives me confidence that my client received an email!

  • Rupok
    • Support Ninja

    Hi brightfuture333,

    Thanks for all these details and glad to see that things are displaying now as you want.

    show the earliest start time and latest end time. ??

    Actually, you can set it yourself. Please go to "Dashboard > Appointments > Settings > Working Hours" section and from the "List for:" option dropdown, select "No specific provider". Then set the starting and ending hours from the bottom options. This will decide the starting and the ending time in your calendar.

    Now, if you want to get the starting and the ending time to be automatic based on the provider, then you will also need to use the "[app_service_providers autorefresh="1"]" shortcode after the "[app_services ajax="1"]" shortcode. So your users will see the dropdown to select service first, then they will have to select a provider from the next dropdown. After this, the starting and the ending time of that provider (whom your user selected from the dropdown) will be shown.

    I believe this will clear all the confusion. Please let us know if you still have any confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.