Title tag for custom post type archive is wrong

It looks like SmartCrawl is grabbing the title of the first post in the loop instead of getting the archive title. A few pertinent facts: the theme is a Genesis child theme, and I'm using Genesis custom post type archives; the custom post type is created using WP Types; the archive is creating using the Views plugin (companion to WP Types).

When I disable SmartCrawl, the archive title is correct.

The site is currently password-protected, but I can provide private access if it's helpful.

  • Predrag Dubajic
    • Support

    Hey Alison,

    Hope all is well :slight_smile:

    I was testing this on my installation with the basic WP setup and everything is working fine there on archive pages so it seems like the one of your plugins is not playing nicely with SmartCrawl.

    Unfortunately all of them are paid plugins and I don't have access to those to test it further on my end.

    Could you provide me with FTP or cPanel access so we can check this further on your end or so we can download the plugins and themes so we can try replicating it on our installation?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - Password for password-protect
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Alison,

    You can go to SmartCrawl > Title & Meta > Archive and toggle author and date archive options there, so you can see if that does the trick for you.

    If that doesn't work, and we can't access your site, could you zip your child and parent theme, WP Types and Views plugins, upload it to any file sharing service like dropbox or google drive and send the download link by using the same contact form from my previous comment?

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Alison,

    Thanks for sending those in, I did some tests on my installation but I was still unable to replicate this issue :slight_frown:

    Could you grant me support access to your site so I could compare your settings and see if I'm missing something on my end to see this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Alison
    • Design Lord, Child of Thor

    You're all set up with support access, Predrag. Thanks so much for looking into this further!

    FYI, there are a couple of places I can point you to within the dashboard that contribute to the archives:

    /wp-admin/edit.php?post_type=capability&page=genesis-cpt-archive-capability
    /wp-admin/admin.php?page=view-archives

    And, of course, you know about the SmartCrawl settings. :slight_smile:

    Thanks again!

  • Predrag Dubajic
    • Support

    Hi Alison,

    If I understand this correctly the archive page we are talking about is /capabilities/ archive, is that correct?
    The one that I can access by going to /wp-admin/edit.php?post_type=capability&page=genesis-cpt-archive-capability and then clicking on capability archive link?

    When I check that page the title looks correct to me:
    [image pos="0"]

    SmartCrawl is active on your site so I'm not sure what I'm missing here, and the same thing is showing on my installation as I have exported your Genesis and Toolset settings and imported it on my installation.

    Can you tell me if there are some additional steps that I need to follow to see this?

    Best regards,
    Predrag

  • Alison
    • Design Lord, Child of Thor

    Yep, that's the correct archive page, and you're right that the page title is printing correctly, but check out the source code:

    <title>Hybrid Configurations</title>

    (This is the first post in the loop, as you can see in the screenshot.)

  • Dimitris
    • Support Star

    Hello there Alison,

    hope you're doing good today and don't me jumping in here! :slight_smile:

    As the support access period has been expired, could you please send us over an email with the following credentials, so I could have another look at this one? As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Dimitris"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.
    Warm regards,
    Dimitris

  • Alison
    • Design Lord, Child of Thor

    Thanks for the reply, Dimitris. Our servers only have SFTP access, so we can't provide FTP access for you. I've re-enabled support access though, and I provided a zip file of the related theme/plugins to Predrag for testing. Let me know if you need anything else, and thanks again!

  • Patrick
    • Support Monkey

    Hiya Alison Happy New Year! :smiley:

    I logged into your site to see if I could help figure out why this is happening. The first thing I noticed is that there appears to be no way to disable the SEO options for the CPT archive view, either in the Toolset plugins or Genesis theme, and that might be interfering with SmartCrawl, or vice-versa (duplicate functionality in multiple plugins can often give such unexpected results).

    As such, I can confirm that when SmartCrawl is deactivated on your site, the meta title correctly reflects whatever is entered in the SEO title field for the Capabilities archive.

    So I've installed the plugins you provided in the email to Predrag Dubajic and imported your Views, Types & Capabilities into my own test site to reproduce your setup there. The same issues are replicated on my site:

    - When SmartCrawl is active, the meta title for the Capabilities archive in source code is actually the post title of the 1st post in the Capabilities archive loop. When SmartCrawl is deactivated, the meta title correctly reflects the archive name or whatever is entered as a custom document title in the archive SEO settings. This occurs whether the archive is set to display as a basic archive or as a custom search under Toolset > Edit WordPress Archive.

    I also double-checked the archives for custom post_types created with our own CustomPress plugin, and notice the very same issue there too. So it would appear we have a situation where SmartCrawl is not recognizing, or not correctly parsing, the data created by/for CPT archives, regardless of the plugin used to create them.

    This does look like it'll need some more digging by the developer & 2nd-level team of wiz-kids... including Predrag who I pinged above. He'll be back from holiday on Wednesday, so should be jumping back in at that time. :slight_smile:

  • Alison
    • Design Lord, Child of Thor

    Thanks so much for checking into this so thoroughly, Patrick...it's much appreciated! I'll look forward to hearing from Predrag when he has a chance to dig a little deeper.

    And we're loving the SmartCrawl updates lately! Keep up the good work!

  • Matt
    • Flash Drive

    Does anyone know if this fix has been implement yet? I'm finding the same problem with my custom post type archives: Archives adopt the title and description of the first post.

    Ultimately I would like to specify custom titles and descriptions for archives of each post type.

    Thanks.

    • Predrag Dubajic
      • Support

      Hi Matt,

      The fix for this is currently being tested by our QA team and is looking good so far so we will see it in next version.

      Ultimately I would like to specify custom titles and descriptions for archives of each post type.

      This sounds like an interesting addition, could you start a new thread in our Features & Feedback section and our devs will consider adding this in future.
      You can start Feature request from chat pre-survey form here https://premium.wpmudev.org/live-support/

      Best regards,
      Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.