Too many products = Exhausted memory, how do I delete products?

Ok, I have increased my memory both server-side (php.ini) and through wp-config.php, however, I think I have too many products because the crash isn't allowing me to view my products list in my admin area. I can only view the categories and something messed up during my import because there's about 20 categories with over 500 products.. Yikes...

Anyways, what I am wondering is, is there a way to delete the products through my phpmyadmin? I am looking there but I don't want to wipe them all if I don't have to. Or is there a fix for this error?

Fatal error: Out of memory (allocated 59244544) (tried to allocate 64 bytes) in /home/f***/public_html/wp-includes/wp-db.php on line 1449

Thanks,
Cody

  • Kimberly
    • Champion of Loops

    Hi Cody!

    Sounds like you have some serious confusion going on there, wow!

    I'm assuming by your use of "yikes..." that you do not intend to have that many products and categories in your store?

    You can go into your wp database and look there for the database entries that collect your Marketpress product data.

    It's a custom post type so if you are running a single site the products will be stored in wp_posts. While you're there look around at which database tables are taking up the most space.

    Let me know what you find!

    Best,

    Kimberly

  • Cody Oelker
    • WPMU DEV Initiate

    Well I found the wp_posts part so now I am sorting through the mess. I don't know what is easier, editing the file in CSV format or just inside phpmyadmin because neither are much fun! Any ideas? I'm not even 100% sure, if I did edit them in CSV and try to import, if they would import without errors.....? I almost feel like scrapping it and starting over but I have a deadline by next week and it may become a mess. Now I'm debating on which process will take me more time, editing or re-doing. lol...

  • Timothy Bowers
    • Chief Pigeon

    Hey Cody.

    You could just up the PHP memory, if you are not sure how to do that then please chat with your host.

    You should be able to do something like add a custom php.ini with the following:

    memory_limit = 256M

    If its htaccess:

    php_value memory_limit 256M

    WordPress also has an option for this which you can add to your wp-config.php file:

    define('WP_MEMORY_LIMIT', '256M');

    You may even need more so you can increase accordingly.

    Take care.

  • Cody Oelker
    • WPMU DEV Initiate

    Thanks for the response Timothy but I have already maxed it out on my server as well as in wp-config. Just to double check, I contacted my host and they verified that I wouldn't be able to do anything short of upgrading my server in which, I cannot afford. I had another post about this earlier but it was more about upgrading the memory for mass products. Now I need to figure out if I am starting over or if I need a new game plan... Either way, MarketPress is doing fine, it's just the server memory. I only have 1 GB at the moment.

  • Cody Oelker
    • WPMU DEV Initiate

    Well I have been uploading the products via CSV spreadsheets one team at a time (NFL teams then NCAA and then MLB) so that is pretty easy and the problem - which I just found out about - is that it has been adding the products twice or three times even on accident. I'm not sure why or how it did this but I think it has something to do with my browser timing out and, I don't know... lol But it turns out that I have like 10 teams that have 500 products so therein lies my problem. I haven't even added all the images to the products yet!

    So, what do you mean by batches? Is that the same as importing CSV files like I am now?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.