Too many redirect error

A subsite with mapped domain showing too many redirects error on a homepage and on a wp-admin page

  • Nastia

    Hello S6Connect

    I hope you're doing well!

    After some troubleshooting on your site looks like there is SSL conflict. The subsite when unmapped with the Domain Mapping plugin deactivated, the wp-admin page still showing Too Many Redirects error and the home page has too many 404 and mix content errors.

    The wp-config.php file looks fine.

    At first. the SiteURL and Home address had the mapped domain added in the filed, from Sites > All Site > Edit site > Settings tab. This is a correct way to map domain when using default Wordpress mapping. Although with the Domain Mapping plugin the SiteURL and Home address had to remain with their original address:
    http://yoursite/subite

    After reverting back to the original address the Too Many Redirect error was still there with HTTPS and HTTP protocol. I've done a quick test for a conflict with another plugin and the issue still persist. I've also added define( 'ADMIN_COOKIE_PATH', SITECOOKIEPATH . 'wp-admin' ); line into the wp-config.php file to see if this issue will be resolved

    Finally to fix this issue I've changed the .htaccess file from this:

    #DirectoryIndex index.cgi index.php
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # BEGIN WP-HUMMINGBIRD-GZIP
    # END WP-HUMMINGBIRD-GZIP
    # BEGIN WP-HUMMINGBIRD-CACHING
    # END WP-HUMMINGBIRD-CACHING

    To this:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    In the end, I've re-mapped the domain on a subsite from Domain Mapping settings.

    Please see if all is well from your end. If you have any further questions, please let us know!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.