Too many redirects on the login page

When I try to log in on WordPress dashboard, the browser says too many redirects, and does not let me get in. Can you help me?

  • Nithin

    Hi David,

    I could see the issue on your website, however, could notice that the website login page does load fine when I try to load via the following link /wp-login.php, ie:
    yoursiteURL.com/wp-login.php

    But couldn't log in to the dashboard in the above instance. The redirect issue seems to be more specific to the /wp-admin URL slug.

    On giving a closer look, the issue seems to be more of a conflict with the Slider Revolution plugin and the security feature most probably added by your host.

    Seems like as part of a security feature, .htpasswds folder is created outside public_html directory, and a .htaccess file is created inside the /public_html/wp-admin directory.

    This file and the folder is more of a security measure, and not part of default WordPress core files, and most probably added by your host, as seen in here:
    https://bestwebsoft.com/some-htaccess-tricks-for-wordpress/

    Once I renamed the mentioned files, and folders from .htaccess to .htacces-off, and .htpasswds to .htapasswds-off , and then deactivating the RevSlider plugin. I could access the /wp-admin.

    This was the error from the Revolution Slider:

    Deprecated: Function create_function() is deprecated in /xxxx/public_html/wp-content/plugins/revslider/includes/framework/functions-wordpress.class.php on line 250
    
    Fatal error: Uncaught Error: [] operator not supported for strings in xxx/public_html/wp-content/plugins/revslider/includes/framework/base-admin.class.php:71 Stack trace: #0 /xxx/public_html/wp-content/plugins/revslider/admin/revslider-admin.class.php(450): RevSliderBaseAdmin::addMetaBox('Revolution Slid...', '', Array, NULL) #1 /xxx/public_html/wp-content/plugins/revslider/admin/revslider-admin.class.php(72): RevSliderAdmin->addSliderMetaBox() #2 /xxx/public_html/wp-content/plugins/revslider/admin/revslider-admin.class.php(44): RevSliderAdmin->init() #3 xxx/public_html/wp-content/plugins/revslider/revslider.php(163): RevSliderAdmin->__construct('/xxx/...') #4 /xxx/public_html/wp-settings.php(322): include_once('/xxx/...') #5 /xxx/public_html/wp-config.php(95): require_once('/xxx/...') #6 /xxx/public_html/wp-load.php(37): require_once('/xxx/...') #7 /xxx/public_html/wp-admin/admin.php(31): re in /xxx/public_html/wp-content/plugins/revslider/includes/framework/base-admin.class.php on line 71

    The dashboard is loading fine now once the above changes were made, and I could log in without any issue.

    The .htpasswds folder, a .htaccess file inside /wp-admin is temporarily renamed, so it's disabled in your system for you to access the dashboard. The redirection issue is caused by this and would recommend you to bring the issue into your hosting provider's attention so that they could point out what's being missed with implementing the security rule.

    Regarding the Revolution slider error message, once the hosting provider has fixed the issue, if you get 500 error once activating the Revolution Slider plugin, then I'm afraid, it's something you'll have to bring into your plugins support.

    I hope this helps. Please let us know if you have any further query. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • David

    Hi Nithin, thank you for finding the problem I will take care but this site is on my VPS and it was working ok till recently. I don't recall to make some changes on the server and also I have other web sites on the same VPS with no problem. Revolution slider probably needs to be updated as it is old. The website is regularly updated all except theme and rev slider. Teme developer did not create any updates and rev slider customer did not want to pay for the update.
    If you have any idea what to do or look on the server please you are more than welcome to give me some ideas.

    Kind regards
    David

  • Nithin

    Hi David,

    If you have any idea what to do or look on the server please you are more than welcome to give me some ideas.

    Sorry for the delay in getting back to you. I just checked the site again, and I don't see the mentioned .htapasswds folder present anymore in your website.

    I guess you deleted it? Since the .htpasswds folder isn't part of the default WP core files, I supposed it was added by your host, since you weren't aware.

    Since that folder is no longer present, I'm afraid, it's tough to say what exactly was causing the specific error. It might be more related to missing some rules in the .htaccess causing the redirect issue.

    Since I don't see the folder, is the issue resolved? Please let me know if there is anything specific I should be looking regarding this, or if I had missed out anything.

    Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • David

    Sorry Nithin, for not back you up with new info.
    I rebuild that web site with the new and more secure theme and plugins and I checked backups and logs sims that I did create that throw Cpanel folder protection feature but never worked I guess be cos security firewall or something.
    But the bottom line is that the teme and some plugins were not supported anymore and I decide to rebuild that web site.
    Thank you a lot for helping me. I would hit the wall with my head for days to solve this.

    Kind regards

    David Imerovic

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.