Too Many Redirects trying to load mapped domain

Hello,
I am using a multisite set up with domain mapping plugin installed. I tried mapping the domain a2zwindowtinting.us to a2zwindowtinting.gkp7.com. When i try to access either site now it brings up a server error
"a2zwindowtinting.us redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS"

I cleared my cookies and it did not work.

  • Kasia Swiderska

    Hello KC,

    I would need to take a look on your settings - on how did you map that domain. Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Do you have any redirects in other places? Like for example in htaccess file? Could you check that?

    kind regards,
    Kasia

  • KC

    I have granted you guys support access.

    I'm not sure if my htaccess file is redirecting anything.

    Here is what is in there currently.

    # BEGIN WordPress

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*/)?sitemap.xml wp-content/sitemap.php [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress

  • Nithin

    Hi KC,

    Hope you are doing good today. :slight_smile:

    Would recommend you to remove the above rules in your .htaccess file, and add the following rules in it:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Domain Mapping has the option to force HTTPS/HTTP accordingly, under Settings > Domain Mapping > Mapping Options

    So once you have added the above .htaccess rules, please force HTTPS through Domain Mapping settings, and then see whether you still get the redirect errors. However, please do make sure to backup your .htacess file, before making any such changes.

    Please do let us know how that goes, have a nice day. :slight_smile:

    Best Regards,
    Nithin