Tooltip from Tooltip Plugin works on normal post type but not Custompress custom post type

Customer is using a plugin for custom tooltips

He is also Using Custompress to create a custom type of post named veterans.

He is also using DIVI theme and some templates from the DIVI library.

The Problem: When we create a normal post the tooltips show well, for example: https://dev.***veterans.com/test-post/

But when on custom post type created with Custompress, in this case veteran, the content does not show the tooltips as expected in front-end. https://dev.***veterans.com/veterans-stories/alan-johnson/

  • urbanhaze

    Guys,
    I appreciate you're trying to help me but I need to say this - with the greatest respect....

    Projects are an in-built CPT provided by the Divi theme
    You can create any other CPT you want but as you can see there are no more other than the Veterans one.

    The problem you're having with the Project CPT was created by yourselves.

    I confirmed this by removing the changed (and broken) version of the Tooltips plugin then reinstalling a fresh version and your test project CPT behaved as normal again:
    https://dev.stockportveterans.com/project/test-project/

    I understand we've agreed this is a development site
    But please, please if you're going to make changes to code you need to document what you've done and be able to undo any changes that you've made before coming back to me and asking me for something you don't actually need please - because it's quite time consuming for me to be debugging additional problems that you're creating.

    Please don't get me wrong, I'm really happy to work with you to resolve this and am grateful for your help, but please use a backup tool or something so you can undo changes that you've made before coming back to me.

    If you need the changes you created I have created a pre-my-plugin restoration backup

  • Ash

    Hello urbanhaze

    I am sorry for the confusion here. I didn't make any change in the plugin code! I just created a new post under project post type and didn't see the content. And then, I tried to select/deselect post type selection for the tooltip settings. No changes were made by me at the code level.

    I can't still see the tooltip to the custompress CPT. We have sent your issue to our second level support team. Please note that, they deal with more complex issues, so there might be little delay. We appreciate your patience on this.

    Have a nice day!

    Cheers,
    Ash

  • urbanhaze

    Thanks for the update Ash,
    That is slightly concerning since the only two accounts with full admin access to make that change are mine and WPMUDEV’s
    And cPanel File Explorer revealed that those files had all been changed on the day I emailed you
    And I didn’t make any changes myself as I was leaving you to test.

    If you’re saying it definitely wasn’t any of you guys that made that change then I fear we may have a security problem - but it is bizarre that the only changes made in the breach were to the plugin that we were discussing was problematic.

    The tooltip still doesn’t appear on the CPT now but at least the content is restored which went missing after the edits to the plugin

  • Ari

    Hey urbanhaze

    Hope you are fine today!

    Just investigated the issue on your site, and I could replicate the issue! But I think this is not related to our plugin actually!

    This is just related to some settings and to DIVI theme.

    Here's the summery:

    I copied the content from https://your-site.com/test-post/ page and replaced the test-doctor and alan-johnson pages content.

    Then I checked these three pages:
    https://your-site.com/test-post/
    https://your-site.com/doctor/test-doctor/
    https://your-site.com/veterans-stories/alan-johnson/

    Unfortunately this is only working with default type not with others.

    ===

    In this stage I wanted to know if the Tooltip plugin is compatible with CPT.

    Then I found there is a setting in the Tooltip plugin to enable and disable the functionality for each post type, you need to allow the necessary post types where you want to display the popups:

    ===

    After updated the settings page:

    This pages started working https://your-site.com/doctor/test-doctor/
    But still not this page: https://your-site.com/veterans-stories/alan-johnson/

    Then I ran a conflict test and found that if I disable the CPT Layout Injector plugin or switch to a different theme the issue gets resolved, I mean https://your-site.com/veterans-stories/alan-johnson/ page start working.

    After further investigation I found that CPT Layout Injector made a custom template for veterans-stories post type, and this template layout was built with DIVI builder. When I reset the template layout, this https://your-site.com/veterans-stories/alan-johnson/ page also started working.

    That means the issue is actually with DIVI builder, maybe with a specific component, so you can report this issue to DIVI team, so they do a probable fix for it.

    Let me know if you need any help regarding this issue!

    Warm Regards,
    Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.