topics do not display in membership protected bbpress

For user of the FVL Schools membership level,
when they use the forum, they can't see what they've posted.

Using bbpress and Membership Pro 2

  • Nastia
    • Support Rock Star

    Hello @Jonathan!

    I hope you are doing well today!

    I just tested FLV Schools Forum pages with Simulation overview and the forum appearing fine. I see only one member has created a topic. Is there only one member having this issue?

    I would like to ask your permission to create an FLV School account and create a new post in the forum?

    Please advise,

    Cheers,
    Nastia

  • Nastia
    • Support Rock Star

    Hello @Jonathan, I trust you are doing well today!

    I wasn't able to replicate the same on my sandbox site with bbPress and Membership 2 plugins.

    I've created a new user on your site with FLV Membership, and indeed I didn't see any topics, although there is a notification above that the topics exist, like it's shown in the attached screenshot. Once I created new topic I saw an error in JS developer console:

    Failed to load resource: the server responded with a status of 404 (OK)

    I made the FLV forum available to everyone in Protection Rules Settings and the issue is still there. I did the same with others type of membership and had the same result.

    The first common reason of this issue is a conflict with a plugin. Would you please run a quick check?

    Deactivate all other plugins, except bbPress plugin, and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let us know how it went!

    Kind Regards,
    Nastia

  • Nastia
    • Support Rock Star

    Hello @Jonathan, I hope you are doing well today!

    So this issue is clearly with bbPress plugin. Please try the following solution posted in bbpress Support forum:

    Add the following CSS code:

    #bbpress-forums .bbp-user-section ul.bbp-topics {
    float: left !important;
    width:100% !important;
    }

    Or if this not work try the following solution I found here:

    #bbpress-forums #bbp-user-wrapper ul.bbp-replies {
        clear: both !important;
    }

    If your theme doesn't have custom CSS field, then you may wish to use a child theme or a plugin like this one for this additional CSS. That way you're protected when you come to upgrade.

    There is also a report that the cache plugin is responsible for this behavior. Do you have activated any cashe plugins on your site?

    If after all this the issue still persist would you please grant support access again from your Dashboard > WPMU DEV > Support so that I can have a look?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please advise,

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.