HTTP error on upload

Transferred to new host Monday. Now, I get an http error when I upload images, either through media library or featured image on posts. Seems like wp-config is pointing to the new host. Permissions for htaccess and uploads are 755.

Tech support hasn't been much help thus far, though they seem well-intentioned. :slight_smile: I have tried on multiple browsers across multiple networks.

After the error notification, I check the media library and the image is there, but will not show up in the single post. This is the latest post, and here is an earlier post that works as is should.

To add to the confusion, the image shows up as the featured image on the homepage, just not on the single post.

I don't know where else to troubleshoot. I know that it was working Monday before the transfer, and hasn't worked since.

Admin access granted.

  • Michelle Shull

    Hi, Josh!

    The support access token had a glitch on our end, so I'm unable to log into your site. I took a look at the pages you linked here, and in the first link, where the image isn't showing, the proper image URL is in the page source, and I can see the image if I directly link to it. The image dimensions are 1px by 1px, which is why you're not seeing it. I did some digging, and it looks like there are a lot of people who have this issue, and not a lot of solutions. Here's what I've found so far:
    1. The issue may be theme specific. Try switching to a default WP theme (like twenty fifteen) and see if your images show as they should in that theme.
    2. Make sure you've got the most recent version of WordPress installed.
    3. If you're using Jetpack, and have the Photon addon enabled, try disabling it.
    4. Try this plugin: https://wordpress.org/plugins/regenerate-thumbnails/ to, as it says, regenerate your thumbnails.
    5. Resave your permalinks. Go to Settings > Permalinks and hit save with your current settings. This updates/refreshes your .htaccess file.

    I attached a screenshot of what I'm seeing in the page source. If the fixes above don't get you hooked up, let us know and we'll be happy to take another look. If that's needed, you can revoke and regrant support access and we can take a look from the admin side as well.

    Thanks!

  • Josh

    Something screwy is going on...I couldn't download TwentyFifteen from WP. I uploaded via FTP, activated it and got an error. Then the WSoD on the whole domain. Delete TwentyFifteen via FTP, reactivated the previous theme, and restructured the widgets how they were, and the WSoD disappeared.

    I reset the support access. If you need FTP or anything else, please let me know. I am lost. I just wanted to transfer hosts...that's all...

    I did try all the other steps also. (Don't use JetPack)

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.