Translation to pt_BR

Follow the steps to try translation unsucessfull - Wordpress 4.7.1–pt_BR

- changed Language in wordpress settings to Portuguese Brazil
- add define ('WPLANG', 'pt_BR'); in wp-config.php file
- copy cp-pt_BR.mo and cp-pt_BR.po to folders:
/wordpress/wp-content/languages
/wordpress/wp-content/plugins/coursepress/languages
/wordpress/wp-content/plugins/coursepress/1.x/languages
/wordpress/wp-content/plugins/coursepress/1.x/themes/coursepress/languages
/wordpress/wp-content/plugins/coursepress/2.0/languages
/wordpress/wp-content/plugins/coursepress/2.0/themes/coursepress/languages
- fixed permission to rw-r--r-- to all cp-pt_BR.mo and cp-pt_BR.po files
- restarted webserver

    Rupok

    Hi Dario Alves Junior ,

    So sorry for the inconvenience you are having. I tried to regenerate this on my test site and I could regenerate the issue. But my colleague Kasia Swiderska tested with with Dutch language files and those language files and Dutch translation are working fine. So the issue is with the translation files for Portuguese language.

    I'm confirming this as a bug and reporting to our developer right now. I believe, she will come up with a fix very soon.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and release a fix. I appreciate your patience.

    FYI: Since version 4.0, wplang define is deprecated. So putting the language files in the "language" folder inside the plugin folder and then changing site language from "Dashboard > Settings > General" section should do.

    Have a nice day. Cheers!
    Rupok