Translation Widget not working

Hello!

I have installed qTranslate and managed a way for it to work with Upfront also in another websites. But, on this site I cannot make the widget to keep the setting I select even though on other websites it worked ...

So, I select show images only and save:

And after, if I check, what I selected is not there anymore ...

Thank you!

  • Luís

    Hi Alex ,

    Hope you're doing well today!

    I tested this in my install and I was able to replicate. However, Upfront is not full compatible with qTranslate, I can suggest you to try add the HTML code inside a Text Widget, as an example:

    <ul class="language-chooser language-chooser-image qtranxs_language_chooser" id="qtranslate-3-chooser">
    <li class="lang-en active"><a href="http://yourdomain.com/wp-admin/admin-ajax.php" hreflang="en" title="English (en)" class="qtranxs_image qtranxs_image_en"><img src="http://yourdomain.com/wp-content/plugins/qtranslate-x/flags/gb.png" alt="English (en)"><span style="display:none">English</span></a></li>
    <li class="lang-de"><a href=""http://yourdomain.com/wp-admin/admin-ajax.php" hreflang="de" title="Deutsch (de)" class="qtranxs_image qtranxs_image_de"><img src=""http://yourdomain.com/wp-content/plugins/qtranslate-x/flags/de.png" alt="Deutsch (de)"><span style="display:none">Deutsch</span></a></li>
    </ul>

    This is an example of the HTML code generated to add a selector with two languages (English and Deutsch). If you need help to find the code for your website, please, let me know.

    Cheers, Luís

  • Luís

    Hi Alex ,

    Hope you're doing well today!

    Unfortunately, there is no translation plugin fully compatible with Upfront yet. Our developers are working to add this feature and we hope to include it in a future release.

    Regarding to my last reply, I would like to apologize about the bad information, I made a mistake during the tests and actually it will not work. However, I made some new tests and I think an workaround could be using CSS.

    This is an example to replace the text for "English" with the flag:

    1) Launch the Upfront editor and add the qTranslate widget;

    2) In left panel -> Theme Settings -> Global Theme CSS, paste this CSS code:

    .qtranxs_text_en span {display: none;}
    
    .qtranxs_text_en {content: url(http://yourdomain.com/wp-content/plugins/qtranslate-x/flags/gb.png);}

    Note: replace "http://yourdomain.com/" by the domain of your website.

    Also, I made a video showing this process, that I think may help you too:

    http://screencast.com/t/4U9Oe32ZWL

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.