[Tribe Events Calendar] Display issues with Tribe Events Calendar

The events are not displaying right, the Title is off the top of the page, and when using the "Events" editor the post information is displayed incorrectly, as in the list of events is unreadable, i have provided Support access to the wpadmin

  • jnkfrancis
    • Recruit

    Hi SEOMCR,

    I took a look at your site, and I found a few things that you might want to look at in your CSS that are causing your pages to load funny.

    I started with the single events page: http://be4.85b.myftpupload.com/event/ilm-level-7-certificate-diploma-executive-coaching-mentoring/2018-01-01/

    There are a couple of CSS rules on that page that are marked !important that are overriding your other CSS rules that make the page display properly.

    On the file http://be4.85b.myftpupload.com/?display_custom_css=css&ver=4.9.8&nocache=1 line 847 you have the following rule:

    div#page-container{padding-top:0 !important;}

    That zero padding overrides your layout that allows space for your nav bar. In this case, you can simply remove the !important property and it will work properly.

    On line 270 you have:

    .tribe_events-template-default h1.tribe-events-single-event-title {text-align: center;margin: -250px auto 50px !important;z-index: 99999;font-size: 50px !important;}

    The -250px margin there, pulls your title up and out of view. In this case, I would suggest maybe a margin of margin: 50px auto; .

    Whenever you use the !important property, you are telling the browser to ignore any other CSS rule unless it is higher in the style sheet AND also has the !important property. So you will want to use it only when absolutely necessary.

    Both of these rules, I found were added using your Add Custom CSS plugin so you should be able to change those rules fairly easily.

    ...when using the "Events" editor the post information is displayed incorrectly, as in the list of events is unreadable

    I took a look at your admin area and I couldn't see the effect you were referring to, if possible could you reply and post a screenshot so I can see what you are experiencing.

    Finally, I know that this is a staging site, but it is highly recommended that you keep your plugins and themes up to date. Out of date plugins can cause conflicts and compromise your security. Also plugins are often updated to add features or improve the performance and you will want to take full advantage of that. If you haven't tried it already take a look at Automate (https://premium.wpmudev.org/blog/introducing-automate/) :

    Automate does two very simple but absolutely essential things for your WordPress site automatically:

    Updates for your plugins, themes and WordPress core files, and
    Runs scheduled backups.

    Thanks!

    Jeremy

  • jnkfrancis
    • Recruit

    Thanks SEOMCR,

    So what is happening is you have more columns enabled in that overview than what the screen size can handle. On my view, I don't have comments, SEO, and Readability and it shows up normally.

    My suggestion would be to experiment with removing columns from that overview that you don't need. You can do that by clicking on the Screen Options tab in the upper right-hand corner and checking or un-checking the different columns to find a view that works for you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.