Tried without success to restore a snapshot while migrating to other web hosting company

Hello everybody!

I'm using Snapshot Pro on my websites and wanted to give it a try and this is a quick feedback as well as a "help" request.

I wanted to move one of my websites from one web hosting company (cloudways) to another (fastcomet) with the same domain name. I followed a complete guide I found on your blog on how to create a backup to migrate a website, made a new backup and changed DNS entries accordingly to point to fastcomet. The .zip archive file is over 200 Mo.

But I was unsuccessful each time.

On fastcomet, I installed a new wordpress installation with same plugins installed. The error I got was regarding a missing manifest.xml file when I tried to import the backup from dropbox.

I also run automatic backups in this case once a day with a retention period of 7 days. They are also synced to dropbox.

Now, from within snapshot pro, all direct imports of my backups using a public shared link generated in dropbox failed with always the same error message about the manifest.xml file that could not be found.

I then tried to upload dropbox backups from my computer to the default snapshot path. Same error again.

My first thought was that it was related to server limitations, but I increased accordingly values before trying that whole stuff. Anyway, I got in touch with fastcomet who was also unable to import backups and they increased even more server limits to allow me to try again.

The last test I made finally worked for importing the backup. I generated a full backup, downloaded it manually on my computer and then uploaded it to my new web host via FTP (had to wait each time because I switched my domain name A entry from one to another and waited for propagation to be ok).

There, I could successfully import my backup and see it listed under all snapshots. BUT... ^^

I restored the snapshot and could see my website as it was... bravo bravo and then... I could login but not access the administrator dashboard! Access denied, not enough permission...

I tried with the second admin account I used to have: same: no dashboard, not enough permission. Same with the one admin account created when I installed the new wordpress on fastcomet.

I even tried through phpmyadmin to compare the user table and the user_meta table to see if for some reason I was not an administrator any longer but no. Comparing those tables from my previous and new database, it was exactly the same.

I also checked the wordpress codex and concluded that I still was admin but something else went wrong.

What I tried next was to disable all plugins throught FTP by renaming the plugin folder but still no change. Was this my mistake? To not have deactivated all plugins before or while importing?

I tried over 2 days, many hours and now, I'm really afraid if one day, I have to restore my website or simply want to migrate it.

For sure, I’m responsible for this but I don’t know exactly what the reason could be.

Would you have any insights ? Is it possible to verify if backups sent to dropbox are corrupted ?

Note that I’m not quite sure that backups sent to dropbox are fully operational. I’m confused and apologize for this long message !

The end of that story is that I reverted back and my website is still running on cloudways which is not a big deal.

Have a nice day,
Séb.

    Nithin

    Hey sebastien,

    Hope you are doing good today.

    Thank you for writing a detailed observation, however it's pretty tough to say what could have gone wrong without checking your system. If you had created multiple backups to Dropbox, does the archive size between them differ?

    It seems like you have reverted to couldways, if you still have access to fastcoment, could you please check the restored database in your new server, and see whether you have the following value defined for wp_capabilities in the wp_usermeta table:
    a:1:{s:13:"administrator";b:1;}

    Here wp in wp_usermeta is the default table prefix, it can vary from one server to another.

    Also, check whether you have wp_user_level value defined in wp_usermeta table. If not, we could correct these by manually adding the values in there.

    Please do let me know how if that's the case, so that I could guide your further on the issue with fastcoment. If not, please enable support access to your cloudways website, so that I could have a better idea about your website, and it's settings.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend.

    Kind Regards,
    Nithin