Trouble activating Multi-DB on clean WPMU 3.0 and BuddyPress 1.2.4.1 install

I am not a very experienced user or developer of WPMU/BP. The balance of my plug-ins have uploaded and installed from the "UPLOAD" console inside WP without issue. This one continue to fail.

PLATFORM: WPMU 3.0 and BuddyPress 1.2.4.1 on Bluehost.

When activating directly after upload and install:

Warning: require_once(/home2/mypolit2/public_html/wp-content/db-config.php) [function.require-once]: failed to open stream: No such file or directory in /home2/mypolit2/public_html/wp-content/plugins/multi-db-3.0/db.php on line 74

Fatal error: require_once() [function.require]: Failed opening required '/home2/mypolit2/public_html/wp-content/db-config.php' (include_path='.:disappointed:usr/lib64/php:disappointed:usr/lib/php') in /home2/mypolit2/public_html/wp-content/plugins/multi-db-3.0/db.php on line 74

Installation creates these 5 plug-ins (which to activate?):

Multi-DB

Activate | Edit | Delete
Version 2.9.2 | By Andrew Billits (Incsub) | Visit plugin site
Multi-DB

Activate | Edit | Delete
Version 3.0 | By Andrew Billits
Multi-DB

Activate | Edit | Delete
Version 2.9.2 | By Andrew Billits (Incsub) | Visit plugin site
Multi-DB

Activate | Edit | Delete
Version 2.9.2 | By Andrew Billits (Incsub) | Visit plugin site
Multi-DB (Conversion Tool)

Activate | Edit | Delete
Version 2.9.2 | By Ron Dillehay - FanMail to rdillehay@hotmail.com (no tech support please) - Modified slightly by Andrew Billits (Incsub) | Visit plugin site

Any assistance would be greatly appreciated. Thank you.