Trouble logging in to Appointments+ with Google+

Hi, I'm still having issues logging into Appointments+/MarketPress. I migrated my site to a dev subdomain to try to get away from possible SSL issues, but none of the logins work. Trying to login using Facebook appears to work, but the user is not logged in. Logging in using Twitter just redirect to the appointments page without logging in. Trying to login using Google+ results in:

"400. That’s an error.

Error: origin_mismatch
Application: XXXXXX
You can email the developer of this application at: XXX@XXX.com
Request Details
=
proxy=oauth2relay814811918
scope=profile email
origin=http://dev.kimkuhlman.com
response_type=code token id_token gsession
redirect_uri=postmessage
state=591804148|0.4063895234
client_id=306326510152-48oj9pqoudod2e3k5bcel2kub40lupbf.apps.googleusercontent.com
cookie_policy=single_host_origin
include_granted_scopes=true
jsh=m;/_/scs/apps-static/_/js/k=oz.gapi.en.8movYjRqroE.O/m=__features__/am=AQ/rt=j/d=1/rs=AGLTcCNhL5_hXUHUHXL_LKiRw4mzRFAS-w
That’s all we know."

Any ideas? TIA!

Kim

  • Michael Bissett

    Hey Kim Kuhlman, Michael here!

    The word I've got from the developer is that the front-end login functionality needs a makeover (which will take some time), so for the time being, I've cooked up a workaround for you, to get the social login working (this will need to leverage the wp-login.php page):

    #1: Install the Super Socializer plugin here:

    https://wordpress.org/plugins/super-socializer/

    And afterwards go to:

    Super Socializer -> Social Login

    And enable the functionality there. For Google+ (and any other providers there), you'd insert the API information you'd previously inserted into Appointments+.

    (side note: if you're only wanting to enable social login [say, if you've already got social sharing set up], you can disable the other options, and just enable the social login functionality).

    #2: You'll want to disable the "Accept login from front end" option in Appointments+, via:

    Appointments -> Settings -> General

    Once that's done...

    #3: You'll want to log in to your site via FTP (we've got a guide over here about that), and replace the following file:

    /appointments/includes/class_app_codec.php

    With the copy inside of the attached .zip file. It's got a patch that'll redirect the user back to the appointment page after logging in.

    Note: When logging in via Twitter, the first time a user does it, he may see a prompt to provide an email address. This would be normal, and is required by the social plugin. Afterwards, he'll be redirected to the appointment page. :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.