Trouble progressing to next unit...

On my unit 1 in our Ethical Decision Making course, there are no assessments and only 1 page.

Unit is set to YES for User needs to answer all required assessments and view all pages in order to access the next unit and NO for User also needs to pass all required assessments

After viewing the page, users click the Next button to be taken to Unit 2 and on the first few tries it says:

"You need to complete all the REQUIRED modules before this unit.

Please press the Prev button on the left to continue."

A few tries (or after some time) later it works...

I've tested this myself with 2 separate test users, both of which have subscriber access as do my students.

The first user test worked after 3 tries and about 15 minutes, as I visited the support forum to look for possible solutions before trying again and being successful.

The second user test I've tried 7 times, clicking [Previous Unit] - scrolling to the bottom of the single page unit - then clicking [Next] - all immediately, but gave me the same error. I then waited 10 minutes more and still getting the same error.