Trouble saving to DB

I am having trouble saving dates in the bp group calender. The message says that it has problems saving to database:

http://awesomescreenshot.com/0ce134jm8f

Where could that come from?

Do there have to be any folders set to 777 or sth. like that?

Harald.

  • Helloweenie

    Hello Jack,

    thanks for answering, it's a good feeling to know that someone will soon help instead of having to do trial and error to find it! :wink:

    Besides PHPMyAdmin I have installed the plug-in: "WP Security Scan" from WebsiteDefender and Akismet for SPAM defending.
    Went through the list and found Exec-PHP as other plug-in that might effect bp group cal but not more as far as I can see.

    Harald.

  • Helloweenie

    Hi again,

    I de-activated all plug-ins and the error still came up.

    Error Log showing up:

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /www/htdocs/w00f1cfb/wp-includes/functions.php on line 2925
    
    Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in /www/htdocs/w00f1cfb/wp-includes/functions.php on line 2839
    
    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /www/htdocs/w00f1cfb/wp-includes/functions.php on line 2959

    Let's hope it will help to find the error.

    Have a great day/evening.

    Harald.

  • Helloweenie

    Hello,

    very sad that we seem not to find a solution!

    OF COURSE I am using newest stable version of buddy press (Version 1.6.5). Theme I am using is from newwpthemes.com

    Through which folders does the plug-in communicate with db? I am asking because my webserver limits access to either web/php or ftp access. All wp-folders are set for access of php-user.

    More thoughts / tests from me: same error accurs when using bp default theme. And: What is the table in db called? Want to check if it's there or not and how it looks and mybe enter sth. manually!

    Harald.

  • Jack Kitterhing

    Hi there Harald,

    I hope you are well today.

    We will find a solution :slight_smile:

    It's clearly a problem with how the hosting is set-up.

    When you say

    my webserver limits access to either web/php
    Which sought of access does it limit? I limit access to FTP myself.

    I have been through all associated files/folders with this plugin in wp-content > plugins bp-group-calender. My folders are 755 permissions and my files are 644
    What are yours set to?

    Also does your error log have a time stamp at all?

    Thank you!

    Kind Regards
    Jack.

  • Helloweenie

    Hello Jack,

    hope you had a great Easter and hopefully without snow as we had over here in Germany.

    The limitation is that I can set in webspace backend panel either ftp access or webaccess (php) for files and folders.

    The folders and file permissions are both set to 755.

    My other thought was of db itself. I might have maybe deleted the table where it writes the group dates into as I tried so many plug-ins before and after using one deleted the empty tables of that plug-in. Maybe I deleted the one bp group cal. needs by mistake? Which is that, how is it called?

    Would it help if I get you access to wordpress and or webspace?!

    Harald.