Trouble with Google Analytics

I'm having trouble with Google Analytic plugin.

Opps forgot to give the error code found on wp-admin for sub-domain blogs

Fatal error: Cannot break/continue 1 level in /home/dapadoo/public_html/wp-content/plugins/google-analytics-async/google-analytics-async.php on line 160

I've removed the old plugin that was in the mu-plugins folder
I've updated to the newest version of the plugin.
When I activate either way, activate or network activate an error message appears in place of wp-admin with all sub-domain blogs.

I've tried with or with out supporters able to use it.

The only way I've been able to get the wp-admin page to reappear in sub-domain blogs is to remove the Google Analytic plugin completely.

Any one now what the problem is?

Could or is this one of the plugins that's not going to work until wp3.1?

If so, what version do I need to go back to? There were 3 released on 1-11-11

  • DavidM

    Hi there dapadoo,

    If you could please refer to the following post...
    https://premium.wpmudev.org/forums/topic/google-analytics-v114

    I believe a workable solution, at least for the moment, might be, as Ivan and drmike mention in that post, to change the "continue" to "return" on line 160.

    So, by going to the Plugins section and selecting to Edit the Google Analytics plugin, you should see the plugin editor screen. From there you could just do a search using your browser's text search (since the editor doesn't have line numbers) to find the term "continue" and change that text to read "return". Make sure to press the "Update File" button at the bottom to save the change.

    Please let me know if this works okay for you or if we need to try something else. :slight_smile:

    The plugin worked fine on my test site just now, so I'm really not sure why the problem occurs in some cases and not others.

    Thanks for your patience,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.