Try this if the emails are not sent

Hello,

I installed this plugin and it was not working. So I decreased the limit in the mail plugin PHP file – mass-mailer.php:

SELECT email_user_id, email_optout FROM {$wpdb->base_prefix}mass_mailer WHERE email_optout<>'no' AND email_status = 'no' LIMIT 500

Changed to:

SELECT email_user_id, email_optout FROM {$wpdb->base_prefix}mass_mailer WHERE email_optout<>'no' AND email_status = 'no' LIMIT 20

Now the plugin works. We used Google Mail SMTP on that site, so the limit might be different for other hosts.

Suggestion for plugin author: I guess this should be in plugin options and the default should be much lower than 500.

Thanks,

Martin

  • aecnu
    • WP Unicorn

    Greetings Martin,

    Thank you for your feedback, it is greatly appreciated and the cure for those wanting to send out emails via Gmail, it is good stuff.

    I must admit that I have this plugin on several sites and a list of around 8000 and I would be horrified if the plugin indeed kicked out emails at a rate of 20 per cycle (my Dual Xeon Quad Core dedicated servers whip them out at 500 a clip with hardly a noticeable load increase).

    Maybe a note should be put in the documents that those choosing to use Gmail to send out mass emails should change their settings to much lower then 500?

    I will certainly consider doing this right away which would also help those with low end hosting too.

    Thanks again for you valuable input and for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.