Trying to get Managed Snapshots to work for the first time.

I installed snapshot and have configured Managed Snapshots to run daily (multisite configuration). However, after more than a week there are no managed snapshot backups. I have tried to run backup now from the hub, but it just brings me to the snapshot configuration page with no option to run the backup now. The log files shows this. [Cron][2017-05-06 11:33:59][Warning] Immediate hook misfired, kickstart backup processing. My backups of individual sites are running and saving to my amazon S3, but I really want backups of the entire multisite to work too. I have my own server in amazon where my wordpress exists. Is there a port that I need to open in my firewall to get the server to server communication to work? I have modified my php.ini file to increase the max_execution_time = 300. I also modified my wp-config.php file with define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);

  • Kevin Knowlen

    To the community,
    I think that I have found the solution to my problem. I had followed lots of the advice from many other threads, including turning on the error logging with:

    define('WP_DEBUG',true);
    define(WP_DEBUG_LOG, true);
    define(WP_DISPLAY, false);

    However, there was no errors to reported from Snapshot Pro in the error log making the problem somewhat elusive. The last thing that I did that I believe solved the problem was increasing the memory limit size to 256M. Previously it was set at 64M.

    define('WP_MEMORY_LIMIT', '256M');

    Other changes I made may or may not have contributed to solving the problem. I had also added the following configs to the wp-config.php file.

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);

    After altering the wp memory limit to 256M the button showed up to run backup now. As of the moment of writing this reply my site is backing up. I hope the scheduled back up will now run automatically.