Trying to get the best out of Hummingbird

Hi - I'm trying to increase my Google Page Speeds Insights score, but the information I am given that I need to correct, I can't.

The readout is as follows:

60 / 100Speed

Should Fix:
Optimize images
Properly formatting and compressing images can save many bytes of data.
Optimize the following images to reduce their size by 255.6KiB (97% reduction).
Compressing and resizing http://i2.wp.com/…9-BRadius8Smoothing4-Edit-3000x540_c.jpg could save 249.5KiB (97% reduction).
Compressing and resizing http://i2.wp.com/…d-IWPDA_2_White.png?zoom=3&fit=512%2C512 could save 6KiB (87% reduction).
Hide details
Eliminate render-blocking JavaScript and CSS in above-the-fold content
Your page has 1 blocking script resources and 2 blocking CSS resources. This causes a delay in rendering your page.
None of the above-the-fold content on your page could be rendered without waiting for the following resources to load. Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML.
Remove render-blocking JavaScript:
http://www.ianwattsphotographyanddigitalart.co.uk/…ache/e0be422d69182006b89b7669bab66f21.js
Optimize CSS Delivery of the following:
http://fonts.googleapis.com/…boto%3A500|Roboto%3Aregular&subset=latin
http://www.ianwattsphotographyanddigitalart.co.uk/…che/0a6b9b3db375732860fe8974be0fb698.css

The images I have optimised with WP Smush Pro, and I have run through minification in Hummingbird. The trouble is the files that Google PageSpeed insights is having trouble with are Hummmingbird Cache files, and don't show up in the minification page of Hummingbird.

I'm not sure how I can improve this if it is files that Hummingbird has created that are causing the problem, or if these images cannot be optimised by WP Smush Pro.

I have granted you access through the support dashboard so you can take a look, and obviously you can run my site through PageSpeed insights yourself. I have also attached a screenshot of the site.

Many Thanks

Ian

  • Nithin

    Hi Ian,

    Hope you are doing good today. :slight_smile:

    The images I have optimised with WP Smush Pro, and I have run through minification in Hummingbird.

    Unfortunately WP Smush Pro can only smush images inside the media library, it doesn't have any control over images served outside the website, the image mentioned in the website is being served from another server, hence it's not being smushed.
    http://i2.wp.com/www.ianwattsphotographyanddigitalart.co.uk/wp-content/uploads/2016/06/2015-11-17-22-52-09-BRadius8Smoothing4-Edit-3000x540_c.jpg

    It seems like you're using Jetpack hence these images are served from their servers. Could you please disable their photon module, and re-smush the images if not smushed, and check whether it works.

    The trouble is the files that Google PageSpeed insights is having trouble with are Hummmingbird Cache files, and don't show up in the minification page of Hummingbird.

    What Hummingbird minification does is compress, and combine all your files into a single file, as seen in your Pagespeed page. So, when it comes to render blocking issues, the only solution is to move the files to footer, could you please move your files to the footer, and check whether it helps. You can find that option under Hummingbird > Minification > POSITON.

    Please do note that moving the files can sometimes break your website layout, as it entirely depends upon your theme, and your theme honors Hummingbirds minification settings.

    If you find the website to be broken, you'll have to tweak each files which is causing this, in order to get your website optimized to it's best.

    Regarding browser caching issue, please check the following url:
    https://www.keycdn.com/blog/local-analytics/

    Please let me know how that goes, and please advise if I had missed out anything. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Ian

    Hi - a quick question:

    For example, one of the files causing a render blocking file error is this:

    http://www.ianwattsphotographyanddigitalart.co.uk/wp-content/uploads/wp-hummingbird-cache/e0be422d69182006b89b7669bab66f21.js

    However, I can't move that anywhere because it does not appear on the minification page, so how can I move it. I'm not sure how to proceed with this?

    I have found the issue with images - for some reason once I put my images in a slider (Soliloquy Slider) the images became huge and became a problem - I am looking for a better slider solution.

    Cheers

    Ian

  • Nithin

    Hi Ian,

    Hope you are doing good today. :slight_smile:

    However, I can't move that anywhere because it does not appear on the minification page, so how can I move it. I'm not sure how to proceed with this?

    You cannot move it because it's already moved, through minification settings. As mentioned before, when you minify, all the files are compressed into one file(or multiple files), and one such file is what you have mentioned above. ie for eg: e0be422d69182006b89b7669bab66f21.js

    So when you actually move the files to footer/header, this compressed file would be the one that is moved. In order to render your pages faster, and to execute scripts these files are essential. What you could do to solve render blocking issue is move all the files to footer, as shown in screenshot below:

    You cannot completely eliminate render blocking issue because that depends upon how your theme renders the minification settings, what you could do is to achieve the best possible score.

    For more info please check this link:
    https://varvy.com/pagespeed/render-blocking.html

    Please let us know if you still need any further assistance. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Ian

    OK - despite my promise I have hit a snag, in that Hummingbird is clashing with a SiteOrigin Theme I am using - according to them:

    "The issue here is that that Hummingbird is outputting after the customizer CSS."

    They suggest:

    "Please check your hummingbird settings and try and adjust when it outputs or alternatively, get it to minify inline styling."

    Now I presume if you are outputting your CSS after WP Customizer CSS I might run into this problem a lot with any theme that uses WP Customizer, as that is now WP's standard place to customise a theme.

    Does what they are saying make sense, and are there some settings for Hummingbird that I have missed that allow me to change things like they have suggested.

    Thanks

    Ian

  • Nithin

    Hi Ian,

    Hope you are doing good today. :slight_smile:

    Please check your hummingbird settings and try and adjust when it outputs or alternatively, get it to minify inline styling.

    What you could do is disable minify, and combine option for the main stylesheet, ie style.css. This should avoid such instances, you can check the screenshot below for TwentySixteen theme:

    Please let us know how that goes, so that we could give a closer look if needed. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello Ian,

    - I keep meaning to look if you have any training videos on Hummingbird - I need to get my head round this whole minification thing.

    There is no videos about that - it is because all sites are different - there is no one general way to configure that feature. Files need to be checked and site tested with each change to find optimal configuration for your site. Unfortunately there is no shortcut in this case.

    I've tested your site with and without Minification (I've done around 6 testes) and issue is not with minification but with server response time. Twice your site got 80 points in google page speed test with minification disabled because server response time was 1,4 sec. When server response was 0,8 and minification was enabled it got 84 points.
    Those times are changing and score is different. This might be issue with your hosting server efficiency. If this is shared popular hosting this is probable. If not then I can suggest contacting your hosting provider about that problem.

    kind regards,
    Kasia

  • Rupok

    Hi Ian,

    I can not say in any way that 80-85 is a bad score. I've seen many sites working with around 60. Considering that, 85 is a pretty neat score. But still, you can try playing with your minification or compression configuration to see if you can get a better score. As Kasia said above, there is no standard for this because different sites use different plugins and themes and different server configurations. So it's tough to say what is the optimum configuration. A fresh WordPress instance can have different score depending on different server configuration.

    So I think, this is a good score. But if you want, I can give a final look on your configuration and try to change some settings to see if that helps. I can not guarantee that I will be able to make it better, but I can surely have a try.

    For checking this, I need to login to your site with Support Access but I could not find it granted. Would you mind allowing Support Access once again so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.