Changes do not Save!!

Trying to modify the Fixer theme, but none of the changes I make are saved, even after pushing Save (both right-click method and control panel). I researched this and people were talking about having to modify something on the server-side? Firefox gives me the “This page is asking you to confirm that you want to leave – data you have entered may not be saved.” pop-up. I’ve installed it in a subdirectory of a Bluehost shared hosting platform. Any solution to this?

  • Tyler Postle
    • CGO

    Hey Merry,

    Hope you’re doing well today! Often a saving issue like this can be due to the max input vars limit being too low.

    Place this into your .htaccess:

    <IfModule mod_php5.c>
    php_value max_input_vars 9999
    </IfModule>

    You can find the .htaccess in the root of your WP install.

    If you are still having the problem after that then can you grant support access so I can have a closer look at the issue? :slight_smile:

    You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back.

    Cheers,

    Tyler

  • CID4Design
    • New Recruit

    Didn’t work…

    Tried giving access…

    “There was a problem enabling support staff access. Please check that you have Admin permissions and that this site is enabled in the API.”

    This is what I’ve researched so far – when someone has this problem, you tell them it’s a mod_security issue and to tell the host to shut this feature off. I’m pretty sure Bluehost doesn’t allow shutting this off via .htaccess, so I’d have to contact them. This is very annoying and I’m worried about deploying an Upfront site and not being able to edit it down the line because of an Apache incompatibility.

  • Tyler Postle
    • CGO

    Hey Merry,

    Thanks for granting access, I see you are getting the same network error “406 not acceptable” in the console as Scott from the other thread is.

    We have a ticket created for this for our developers to look further into and see what the best way around it is. Our best solution right now is to contact the host and turn off mod security if you can’t do it yourself but we will post an update back here once our developers have investigated further.

    If you have any further questions in the meantime just let us know :slight_smile:

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Hey Merry,

    Thanks for chipping in here @alex :slight_smile: sending some points your way.

    I heard back from the dev on this and it really depends on which mod_security rule got tripped – disabling this particular rule for /wp-admin/ path, or even disabling modsec for /wp-admin/ path should solve it (/wp-admin/ because our AJAX requests are handled by the standard AJAX handler) – provided the host allows .htaccess-level changes. And if the host doesn’t allow changing modsec rules via .htaccess then you will need to contact your host and have them do it from their end.

    Either way, this should be a one-time only change :slight_smile:

    You can start by trying out Alex’s .htaccess suggestions above and if that doesn’t work then it’s likely you will need to get your host to make the edit.

    If you have any further questions just let us know.

    Cheers,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.