Trying to speed site up

I am trying to speed my site and have used the Hummingbird and wpsmoosh, which have helped. I did a google page analysis and got this recommendation:
Enable compression
Compressing resources with gzip or deflate can reduce the number of bytes sent over the network.
Enable compression for the following resources to reduce their transfer size by 249KiB (69% reduction).
Compressing https://cruzfirm.com/…alient/css/fonts/fontawesome-webfont.svg could save 249KiB (69% reduction).
Is this something that will conflict with Hummingbird? I am a designer, not a programmer so this is a bit out of my comfort zone.

  • Nithin

    Hi Monica,

    Hope you are doing good today. :slight_smile:

    I checked your website in Google Page speed, and I could notice what you are saying, do you have any cache enabled? If yes, please try purging it, and see whether it works?

    Could you please try adding the following code in your php.ini file. If the file isn't present, you'll have to create a php.ini file inside your root directory, and add the following rules to it:

    zlib.output_compression = On

    Please check whether this helps. If you still have issue, please enable support access so that we could have a better idea about this. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Monica,

    Thank you for enabling support access, I could see it's a GoDaddy Hosting, could you please remove the above code, and add the following in your .htaccess, and see whether it makes any difference for Gzip compression. Please don't forget to flush the cache of your homepage, before checking the result in Google Page Speed.
    php_flag zlib.output_compression on

    You can find the file .htaccess located in your root directory.

    And regarding render blocking issue you have raised, and I checked your website, and I could see the that your website is configured at it's optimal best. You could try moving the files individually to the footer, and see whether it improves the score, however moving the files might break the websites layout, as it entirely depends upon on how your theme honors the minification settings.

    If you find that moving a particular file breaks the layout, you'll have to keep that in the original position, and then try moving other individual files, and check whether it works. You'll have to flush your cache, in order to see the results in the page speed score.

    I could see 2 images that are still marked as it needs compression, however the images seems to be smushed in your system, under Media > Library

    Compressing https://cruzfirm.com/wp-content/uploads/slide-1-EN-1.jpg could save 23.5KiB (12% reduction).
        Compressing https://cruzfirm.com/wp-content/uploads/fondo-cuadros-3.jpg could save 1,018B (23% reduction).

    This could be related to your website cache, I tried clearing the cache, but I'm not able to see any changes. Could you please check with your host whether the cache could be disabled? if not, maybe clear the cache from their side to see whether it improves, or not.

    Please do let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Monica

    Thank you - I am not sure which code you want me to remove...

    "Thank you for enabling support access, I could see it's a GoDaddy Hosting, could you please remove the above code, and add the following in your .htaccess, and see whether it makes any difference for Gzip compression. Please don't forget to flush the cache of your homepage, before checking the result in Google Page Speed.
    php_flag zlib.output_compression on

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.