Trying to transfer a Multisite to WPMU Hosting

I am trying to Migrate a Multisite using Shipper but after waiting for 12 hours for its Pre-flight check to get over, I initiated a manual backup. I figured that pre-flight check was stuck as the IP was being blocked by my server.

Upon manually migrating, I am now unable to browse the wp-admin panel after I changed the Site URL & WordPress URL in database. I am getting Database error.

Kindly help.

  • Adam Czajczyk

    Hi WP Chef

    I hope you're well today!

    There are actually two issues here. The first one was a database connection error but this got solved by simply flushing Object Cache on the server. However, after that the other issue got revealed and this might be a bit more complex (though not necessarily).

    The thing is with that "manual" migration. I believe you have downloaded all original files to your local machine and then "bulk uploaded" them via FTP and you're most likely working on Mac, right?

    For some reason the "meta data" files that got created. Those files are easy to recognize because they are copies of existing files, but prefixed with

    ._

    Some of them are .php files which got executed on server but the filesystem on server doesn't recognize these files (which are specific to Mac). I'm not sure why actually the got uploaded as I'm not a Mac user and I'm not that familiar with it's OS "quirks" but I know it happens and is related. Since they are not supported on a server they are "getting in a way". In fact, that could happen (and we had similar cases reported) an any host - not just ours.

    So basically, the point is to clean up entire install of these files.

    Doing that manually would take quite some time and won't be easy. Much simpler way would be to "re-upload" entire "plugins" folder this way:

    - create a zip file directly on a source server
    - upload it to the target server
    - unzip (extract) it directly on a target server (via SSH)

    However, while I was working on the site it suddenly started to redirect me to the epk...com domain which is also pointing to a different IP than the epk.... wpmudev.host. I'm slightly confused now as I'm not sure if you changed something with the domains or the site got up but it's redirecting to the domain that's actually on another server. Can you tell me if you were making some changes just about now, please?

    Best regards,
    Adam

  • WP Chef

    Good god I need to re-upload everything??? It took forever! I would prefer using Shipper to migrate the site or perhaps another plugin if you can recommend one.

    As for the redirect that's happening... I'm not sure what to say. The original database is setup for subdomains and I'm trying to convert that to subdirectories. So I updated the urls in the database as shown in the attached screenshot (partial update so you can see the difference).

    I also updated the tables for the parent site URL, perhaps the best thing to do is to a find/replace on the database to change all occurences of epkhosting.com to epkhosting.wpmudev.host ?

    Please advise
    CP

  • Adam Czajczyk

    Hi WP Chef

    Thanks for explanation about the domain. I think that in that case that redirect simply confirms that site started working.

    But - I just wanted to take a look at the database and meanwhile I checked FTP. Are you actually re-uploading everything now?

    It's probably my fault that I didn't make it clear and I sincerely apologize for this. It's most likely too late but let me explain what I meant anyway. The point was to reupload the "plugins" folder only. That can be done quite fast and easy by compressing the folder to a .zip file on a source server, then using SSH on WPMU DEV Host to directly download (that goes very fast) that zip file straight to the host and uncompress (extract it there).

    In fact that can also be done with entire setup as long as you do have cPanel on a source server.

    I can help you with that if you want but I'd need cPanel access credentials to the source (original) site and a path where it's installed (so I wouldn't fetch wrong files). I noticed also that you deleted literally "everything" - did you first made a copy of "wp-config.php" file from WPMU DEV Host? Or do you have db username and password noted down?

    If you want me to assist you with this, let me know please and provide me with aforementioned information by sending them directly to me.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - WordPress admin username
    - WordPress admin password (these are so I could check if the install works fine)
    - cPanel credentials (host/username/password) for original site
    - Folder path to site (for original site)
    - Link back to this thread for reference
    - Any other relevant urls/info

    Kind regards,
    Adam

  • WP Chef

    Hi Adam,

    Thanks for offering to help. I do have a backup of the wp-config.php file. I did delete everything. I am about to upload a zip file into /site/public_html/backup/ and from there I'll unzip and then move the files where they need to go.

    I should be ok to complete this on my own... if I run into any issues once the upload, unzip, move is finished I'll post an update. Fingers crossed.

    CP

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.