Trying to uninstall Pro Sites to do a reinstall

Sorry to have to select WPMU Dev Dashboard - Pro Sites is the problem but it wasn't in the drop down and I couldn't go on without selecting something.

I have a multisite install with the latest WP and all WPMU plugins are up to date. http://negotiari.com.

I have installed Pro Sites but it does not appear to be functioning correctly - in particular, the automatic free option is not working.

So I tried to remove it from the plugins and re-added (it still remembered all of my settings.)

Next I removed from plugins and deleted the 3 tables that had pro-site in the name in MySQL.

I cleared cache.

Still it remembers the settings.

What am I missing on the uninstall process to basically get a "do over" on Pro Sites?

Thanks much
Angela

  • Angela
    • New Recruit

    Hi @Patrick

    It was a new install. I switched servers and did a complete re-do. I tried adding some levels and it seemed to work but I created a new site and could not access it without making a payment.

    I then tried changing 1 to free and 2 to pro (relabeling all of the plugins, themes, etc) and it still wanted a payment even though the amount was zero. That's when I tried going to re-do route.

    I deleted the prosites directory, dropped the tables, downloaded a fresh copy of prosites, cleared my cache, then copied it back to the plugins directory. But the data remained.

    FYI - I first went to WPMU to tried to install again, but it showed the product already installed.

    Thank you!
    Angela

  • Angela
    • New Recruit

    Hi @Patrick
    I think I have my issue resolved but I would still like to know how this works if there is any further insight.

    I am able to use the Free option again - which was my initial problem - just not 100% sure on why. If I break it again I will pass it on along with what I did to break it. :slight_smile:

    Thank you for the help.
    Angela

  • Angela
    • New Recruit

    Here is the response on another question from @Alexander Rohmann:

    "The settings were retained because they're stored via the Wordpress settings API. Many plugins operate this way. Wordpress has functions to allow data to be stored on in it's database tables for long term use.

    Pro Sites uses this for several things, such as coupons, the levels, and all the basic settings. When the plugin is activated, it checks if they are already there, and if so it leaves them, otherwise it populates with default values."

    Here is the link in case anyone else has the same question/issue!

    https://premium.wpmudev.org/forums/topic/pro-sites-keeps-changing-site-status?replies=7#post-409736

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.