Trying to upgrade Multi-DB plugin, but am getting an error

I have the Multi-DB plugin working as expect since version 3.1.6

However, anytime I have tried upgrade to a higher version since 3.1.6 (by method of replacing the db.php file with a new file) I get an error and must revert back to the 3.1.6 db.php file to get the site back to working.

My problems are similar to the ones mentioned in this post:
https://premium.wpmudev.org/forums/topic/upgrading-multi-db-but-get-error

Please review, as I would like to be using the latest version of the plugin.

Thank you.