TTFB HELL! (Time to First Byte)

Greetings!

I'm not sure how much detail you want so please disregard anything irrelevant and move on.

My website has been through struggles for the following reason...
Consistently experiencing a 7 second delay in TTFB (Time to First Byte) "

My checklist of what I did to try to resolve this.

1: Changed hosting Company... now with Network Solutions; now on "Premium Web Hosting Package
2: Upgraded RAM size in httaccess file
3: Disabled ALL plugins (to test with same results)
4: Still have same issue. (Time to First Byte) (7 second delay in "first byte")
5: Purchased your "Plug-in Package"
6: Installed several features of your application.
7: Smushed pics, shrunk code etc.
8: Although your application helped in numerous ways... I have (7 second delay in "first byte")
9: Tested a file access from my hosting server.. Large image and 4 Meg video
Both downloaded instantly from my hosting server.

Is there any way you could
A: See if I'm using your program (Apps) correctly or am I missing something?
B: Relay to me ANYTHING that would make sense to resolve this.

Follow up question..
*** If a new theme is involved because of theme or scripts in theme...
Although I have recent backups from WordPress "All Content" saved locally, is a new theme easy to switch without having to redo a lot of design work?

One last comment...
The Site loads very fast once first byte is released. (under 1 second) IN ALL TESTS MENTIONED

Thank you in advance.

Dan M

  • Dimitris

    Hey there Dan Mitchell,

    hope you're doing good and thanks for reaching us!

    I just inspected your website and was able to experience this slow first byte...:thinking:

    Is there any caches involving in your installation? Server implementations like varnish and memcached could really make things super fast.
    Also CDNs can provide some extra boost serving your media. CloudFlare is a famous solution which provides multiple tools and include a free plan as well.

    On the other hand, you may also experience great difference using another theme but should require some more testing. The proper way would be to create a staging environment in your server, meaning an exact copy of your website in another location/path and domain so you can use for testing. You can always give a spin to our UpFront theme or other themes, but the amount of work needed to further redesign it it heavily depends on you, the customizations made already in current theme and what kind of "needs" the new theme will have.

    If you wish to have a look at your current setup, please grant us with support access via WPMUDEV -> Support -> "Grant Support Access" button. More details on this can be found in our manual page here https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Warm regards,
    Dimitris

  • Dimitris

    Hey there Dan Mitchell,

    hope you're having a beautiful day! :slight_smile:

    I just went ahead and quickly inspected your website. It seems that if I'd changed something it will be one if the points I previously mentioned as everything else seems to be setted up correctly (good score you have in there in HummingBird, good job!).
    1. Server with some more advanced cache systems implemented.
    2. CDN service for quicker serving times. You can always use a free CloudFlare account to link to HummingBird and see if it makes some noticeable difference.
    3. Check performance with another theme. For that you may have to create a staging environment, meaning an exact copy of current site in another location in the same server. This could be used for testing purposes and benchmark performances after changes in theme and/or plugins.

    Take care,
    Dimitris

  • Dan Mitchell

    Good day Predrag!

    I sent a ticket from my hosting support and received the following message.

    "The reason the load time was longer the first time accessing your site was that your cache was set to expire in 600 seconds (3 minutes). You were also using PHP caching rather than mod_rewrite caching which is less efficient. I updated the timeout to 86400 seconds, which is the recommended setting for a fairly static page (as it appears that your home page is fairly static content) and the page appears to load much more quickly. If you have other pages on the site, you can check the documentation for WP Super Cache how to set it so those pages are not cached so they update more quickly. If you make changes to the home page, you can always manually clear the cache files by using the "Delete Cache" button on the settings page for the WP Super Cache plugin "

    Although I recognized a difference 6 hours ago, it seems it is right back to where it was...
    Especially when navigating away from home page and on to a different page of site. (Example)

    Was loading site wide 6 hours ago in under 1.7 seconds (total) on any page.
    This morning, although scores are going up, Pingdom, Hummingbird, Page speed etc... still scratching my head.

    Thank you for your interest in the resolution.
    I wish I could tell you everything is fine but I am convinced your plugins helped in many ways... I'm still scratching my head.

    All the best!
    Dan

  • Dan Mitchell

    I Removed "Super Cache" (That plugin seemed to have issues with my SSL... well documented but I missed it as I applied SSL after installing.)
    Installed Total Cache and set it up per instructions.

    Best I can tell is that Time of day seems to be effecting TTFB.
    While changing caching programs helped with page load speed, TTFB did not change and remains the same at similar times of day.

    I am EST USA.. so, working hours here equate to longer TTFB.

    Getting new hosting today, and setting exact site up to see if there is a noticeable difference.

    If it fixes issue... YAY!!
    If it remains the same, I will strip site down and rebuild much simpler, even though I dread redoing it again.

    I'll keep you updated.

    Thank you so much.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.