Turning OFF Hummingbird Caching for updating software

HI.

I am running into problems with Hummingbird on MANY sites, especially when it comes to caching and leverage browsing in conjunction to updating site software. Where is the off switch?

Once Browser Caching is enabled how do I disable it?

Please advise.

  • Andy

    David If your server is Apache and you've used the automatic enabling option then there will be a button to disable it. Alternately if you manually added the required code after following the instructions for your server type, then simply remove that code again and your caching will return to your default settings.

    Alternately to all of that, you could specify a less-than-recommended cache timeout to suit your needs. 8 days is a guideline, but for updating software regularly you may want to compromise on how long assets are cached for.

    I am not a super guru there, but those methods should help.
    Andy

  • David

    Hi.

    I am on a dedicated server provided by Bluehost:

    I believe it includes Easy Apache 4.

    Server Version: Apache/2.4.25 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4
    Server MPM: worker
    Server Built: Jun 20 2017 14:22:07

    RE: If your server is Apache and you've used the automatic enabling option then there will be a button to disable it.

    Q: where is this button? Are you referring to a Hummingbird dashboard setting?

    If so I see no such button.

    Here are a couple of screenshots of my Hummingbird Settings:

    https://www.screencast.com/t/RERutCyJ91ir

    https://www.screencast.com/t/ueLKEvvbs

    RE: Alternately if you manually added the required code after following the instructions for your server type, then simply remove that code again and your caching will return to your default settings.

    Q: Where and how?

    RE: I am not a super guru there, but those methods should help.

    Q: is there a WPMUDEV Support member that can reply to this ticket?

    Please advise.

  • Dimitris

    Hey there David,

    hope you're doing good today! :slight_smile:

    Q: where is this button? Are you referring to a Hummingbird dashboard setting?

    This is the "Disable Caching" button that Andy mentioned above.

    Could you please try to "recheck files" and check if this is coming up?

    You can also connect to your server, edit .htaccess file of this installation and check for any HB rules wrapped in some comments like this:
    # BEGIN WP-HUMMINGBIRD-CACHING
    *** the rest of the browser caching rules ***
    # END WP-HUMMINGBIRD-CACHING

    If this still troubles you, please grant us with support access to the website in question via WPMUDEV Dashboard plugin as described here (no need to share credentials):
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Q: Where and how?

    I can see from your screenshots that these values are already set to 30 days rather than 8 days which is HB's default settings.
    Did you manage to fine tune this already?
    Or this is happening from the beginning, meaning that there're some other server-side settings for that?
    Please advise! :slight_smile:

    Q: is there a WPMUDEV Support member that can reply to this ticket?

    I've already moved this thread to our Support forums, as the Members forums you've used is more appropriate to engage other WPMUDEV members than support staff.
    For any kind of support queries, please use our support page here:
    https://premium.wpmudev.org/support/

    Warm regards,
    Dimitris

  • Dimitris

    Hey there David,

    hope you're doing good today! :slight_smile:

    Could you please edit .htaccess file of this installation and check for any HB rules wrapped in some comments like this:

    # BEGIN WP-HUMMINGBIRD-CACHING
    *** the rest of the browser caching rules ***
    # END WP-HUMMINGBIRD-CACHING

    It seems to me that these rules may not be used at all in this file, that's why HB's Browser Caching can't be deactivated from there. This would mean that this 30-days expiry duration should be set from another server setting, most probably made by your hosting provider.

    Warm regards,
    Dimitris

    PS. Dear Luke, as we keen on keeping threads specific with one member and issue each time, please feel free to reach us here https://premium.wpmudev.org/live-support/, if this is still an issue in your end.

  • Andy

    David just do follow up here. From your replies and screenshots it appears Hummingbird hasn't had an involvement in setting up your browser cache settings - it's being set somewhere else, most likely by Bluehost's default server setup. That'll be why there's no disable button appearing, and HB is just reporting that your cache settings are already active and set to 30 days.

    It would pay to get in touch with Bluehost and ask them how to adjust your browser cache settings or see if they can do it for you. :grinning:

    Cheers,
    Andy

  • David

    This is what I see in the .htaccess file that may be relevant:

    # BEGIN WP-HUMMINGBIRD-GZIP
    
    # END WP-HUMMINGBIRD-GZIP
    
    # pass the default character set
    AddDefaultCharset utf-8
    
    #Start compress text files
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE image/x-icon image/svg+xml application/vnd.ms-fontobject application/x-font-ttf font/opentype
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/x-font-truetype
    AddOutputFilterByType DEFLATE application/x-font-opentype
    AddOutputFilterByType DEFLATE font/eot
    AddOutputFilterByType DEFLATE font/opentype
    AddOutputFilterByType DEFLATE font/otf
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    <FilesMatch "\.(css|htc|js|asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|json|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$">
    SetOutputFilter DEFLATE
    </filesMatch>
    </ifModule>
    # END Compress text files
    
    Header unset Pragma
    FileETag None
    Header unset ETag
    
    ## EXPIRES CACHING ##
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresDefault "access 1 month"
    </IfModule>
    <FilesMatch "\.(css|htc|js|asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|json|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$">
      ExpiresActive on
      ExpiresDefault "access plus 1 month"
    </FilesMatch>

    Is there and problematic indicators in this code?

    • Andy

      That is really helpful. This is now getting too technical for me so I have pinged our Hummingbird devs to help you out, they should reply shortly!

      P.s. Everything under ## EXPIRES CACHING ## seems to be the culprit as it's referring to the same amount of time showing in Hummingbird. If that is the case, removing those lines and letting Hummingbird control this may be the best option but I'd wait to get clarification from our dev guys.

      Cheers,
      Andy

    • Anton Vanyukov

      Hi David,

      You can just remove these lines:

      # BEGIN WP-HUMMINGBIRD-GZIP
      
      # END WP-HUMMINGBIRD-GZIP

      and comment out this part:

      <IfModule mod_expires.c>
      ExpiresActive On
      ExpiresByType application/x-shockwave-flash "access 1 month"
      ExpiresByType image/x-icon "access 1 year"
      ExpiresDefault "access 1 month"
      </IfModule>
      <FilesMatch "\.(css|htc|js|asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|json|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$">
        ExpiresActive on
        ExpiresDefault "access plus 1 month"
      </FilesMatch>

      After that press 'Re-check status' on the Browser cache page and you should be set.

  • Dimitris

    Hey there David,

    hope you're doing good today! :slight_smile:

    Comments in .htaccess file are set for each line separately with the # character, for example

    # a comment line
    # another comment line

    I've just logged in your website and after hitting the "re-check status" I can see that browser caching is now disabled! :clap:

    Let us know if further assistance is required here!
    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.