Twitter and Facebook Smartcrawl OpenGraph

I need help setting up OpenGraph

  • Dimitris

    Hello there Michelle,

    hope you're doing good today! :slight_smile:

    There are a number of possible explanations for this:

    Your website has a robots.txt file that is blocking Twitter from getting your Card metadata. To learn how to diagnose this case, click here.

    Your Apache .htaccess file is denying requests.You can check this by opening your .htaccess file and looking for something like the following:
    deny from 199.59.156.*
    Be sure to remove any deny directives from your .htaccess file.

    An image is too large for our web crawler to download. Our web crawler will typically download up to 5MB images. If you are seeing this issue, you may want to scale down the size of the image significantly and try again.

    A network lag is causing a delay in fetching your site/images. If your server is in a remote location and/or has unreliable network access, our web crawlers may have difficulty downloading your meta tags and/or images. Please retry as necessary.

    Your web host may be blocking web crawler access to your site. You should contact your hosting provider and ask them to ensure they are not blocking Twitter access by either IP or ASNUM. Twitter’s aggregate outbound IP ranges are 199.16.156.0/22 and 199.59.148.0/22. Twitter’s ASNUM is AS13414.

    Reference: https://developer.twitter.com/en/docs/tweets/optimize-with-cards/guides/troubleshooting-cards#15_seconds

    Please try to check robots.txt and .htaccess in the root directory of your WP installation (where wp-config.php is) for above points.
    If you can't locate anything like that, please contact your hosting provider to double check that they don't block any Twitter IPs as mentioned above.

    Looking forward for your results!
    Take care,
    Dimitris