Twitter not working with Comments Plus

On request by Pranaya Chaudhary I am recreating a new thread regarding the above.

Ok I am giving this another try and alas I am back to the same old Twitter problem.

See here and try to login with Twitter – http://compacthealthsystems.co.za/products/massage-tables-beds-fixed-steel-framed/

Keep on getting error:”There is no request token for this page. That’s the special key we need from applications asking to use your Twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake.”

I am using WP Multisite with Domain Mapping.

A have resetted Twitter keys & nothing seems to want to work.

I had this problem before & gave up and reverted back to Disqus – but then I have no SEO value on my comments and I don’t have proper sharing to Facebook etc.

I have furthermore also noticed that when commenting with Facebook login the author name displays as “Anonymous”.

  • aecnu
    • WP Unicorn

    Greetings Fanus van Straten,

    Lets dig right in and see what is happening there.

    I cannot replicate the Twitter issue in which I am going after first on my production server: http://testing.aecnuwpmu.us/test-for-the-featured-image-in-scholar/

    Do you have more then one twitter application running on your installation?

    Are there any unseen spaces in the twitter application keys? (Common occurrence when things are copy and pasted.)

    Are you running a caching plugin?

    Please advise.

    Cheers, Joe

  • Fanus van Straten
    • Site Builder, Child of Zeus

    @aecnu – Thanks for the response

    1) "Do you have more then one twitter application running on your installation?"

    Just disabled po.st which is a sharing plugin and the issue persists. There are no other Twitter apps.

    2) Are there any unseen spaces in the twitter application keys?

    Just double checked by copy/pasting to notepad first & then to WordPress. No joy.

    3) No caching plugin – don't really believe in them since my server is fast enough.

  • Fanus van Straten
    • Site Builder, Child of Zeus

    As you can see I have really tweaked the styling of Comments Plus to play nicely with the theme I am using on this site and I have done some test comments and all work well except that with a Facebook login there is also a problem in the sense that an Author Name shows up as “Anonymous” in comments and also the Google Login doesn’t work, one get’s taken to your Google account sttings and that’s it.

    http://compacthealthsystems.co.za/products/massage-tables-beds-wooden-framed/

    The question arises – Is it really worth my effort to spend more time in trying to make this plugin work or should I rather revert back to Disqus?

    Maybe this plugin was built to work on Apache servers only and not on Nginx. All my servers are running on Nginx and on all the multiste installations I have Comments Plus doesn’t work. I have not tried it on a singe site install yet – will be a waste of time though since I don’t bother with single site installs anymore.

  • elenapro
    • Flash Drive

    Hi there. Identical problem with Twitter. All of the recommended steps here and in other similar posts don’t resolve the issue.

    Question: how does the oauth_token= appear in the Twitter window? My value is empty, like in screenshot by Fanus.

    https://api.twitter.com/oauth/authenticate?oauth_token= NO ACECSS TOKEN HERE…

    Another problem I have is the formatting of the tabs – they look broken, see here:

    http://goappdeveloper.com/10-things-that-entrepreneurs-can-learn-from-kiteboarding/. Only tick box that I can think of (Shrink or stretch provider selector tabs?) does nothing.

    So, I am subscribed to this thread as well…

    Thanks.

  • Fanus van Straten
    • Site Builder, Child of Zeus

    @elenapro – I have been trying to resolve this one forever and have now ultimately disabled it again. It just doesn’t work for me, not even with the default theme and all plugins disabled – http://pinsoftstudios.co.za/comments-plus/2012/12/21/hello-world/

    I managed to style it properly but that’s about it and that doesn’t help since only the Facebook & WordPress tabs can login properly. The Twitter & Google logins has never worked for me. I guess it still it still needs work so I am therefore not going to waste any valuable time on it anymore until hopefully one day.

  • aecnu
    • WP Unicorn

    Greetings Fanus van Straten and elenapro,

    Are you both running nginx?

    @Fanus van Straten if your server is so good and fast that you do not need to run caching – in which I believe caching is a poor mans hardware replacement, then why are you going through the trouble of running nginx? Just curious?

    As I have previously mentioned – I cannot replicate the Twitter issue in which I am going after first on my production server: http://testing.aecnuwpmu.us/test-for-the-featured-image-in-scholar/

    Dual Xeon 5240 Quad Cores, 16GB RAM, 500GB 6Gbps HDD, Centos 5.8, Apache.

    Do you both or either of you get the Pop Up windows that wants you to log into Twitter as shown on my test installation?

    Please advise.

    Cheers, Joe

  • Fanus van Straten
    • Site Builder, Child of Zeus

    @elenapro – In all honesty I have tried to make this plugin work for me before.

    I have managed to style it according to my needs so that part is ok.

    However on the Twitter issue – I have also noticed that the token is missing on the popup.

    Ultimately the time and effort spent on trying to fix this is not worth it for me so I have reverted back to Disqus for now.

    Once WPMU Dev has spent more effort on this to try and resolve this for all I will dig into this again.

    It’s all a question of priorities when it get’s to web design/development and this is not priority in my case.

    I do however like the SEO & social share value of this plugin and sincerely hope that WPMU Dev will look into this.

    I have noticed that the are using a comment system with a different look on their wpmu.org site so maybe there is hope on the horizon with a new version:wink:

  • Fanus van Straten
    • Site Builder, Child of Zeus

    @aecnu – Thanks for the response

    Yes I am running on Nginx and no I do not bother to use a caching plugin for WordPress since I do not believe in WordPress caching, it just causes endless problems and it's really not necessary if one has your own server running on Nginx.

    Do you both or either of you get the Pop Up windows that wants you to log into Twitter as shown on my test installation?

    Yes I can see the popup on your installation and it works fine but however on that same popup on my installation it does not work.

    I have setup a bare bones test site – http://pinsoftstudios.co.za/comments-plus/2012/12/21/hello-world/ – with no plugins active and with the 2011 theme and it still yields the same error as can be seen in the screenshot.

  • aecnu
    • WP Unicorn

    Greetings Fanus van Straten and Elena,

    There must be something you folks are doing different and everyone knows I am not a coder and did something special to make mine work.

    And if in the event I had I would certainly share it with those having issues, it would just not make sense to not share the fix if indeed I knew of one.

    I would normally at this point copy the site to one of my servers to try to prove out that it is the host as I have done for many others and about 10% of the time I am proven wrong but 90% of the time I am absolutely right and no smoke and mirrors because they are for the most part exact duplicates using the cPanel transfer mechanism.

    And in this event know I will not tell their current host how to configure their servers in which I consider mine to be proprietary configuration. (If you folks do not already know I own a hosting company and I am not a reseller)

    With that said and enough of my blather, since I do have significant information from you folks (well Fanus for sure) in regards to this matter though I have been unable to help find the root of the issue myself, I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    By the way – Happy New Year to you both!

    Cheers, Joe

  • Vladislav
    • Dead Eye Dev

    Hello,

    Have you perhaps tried resetting your Twitter app keys and using the new values instead? The missing oAuth access token means there probably was some sort of issue in communication between your server and Twitter – an obvious possibility here is missing and/or misconfigured cURL extension. Another possible cause of the issue is the time difference between your server and the Twitter servers – if this is the case, syncing your server time can help solve this issue for you.

  • aecnu
    • WP Unicorn

    Greetings Fanus van Straten,

    Thank you for letting us know and sorry to see that it is not working out for you in any event for whatever reason.

    Hosting configuration is of the utmost importance and Curl is an integral part in which we never touched on and if indeed curl is not installed and configured on the server/host then no doubt this will not work correctly.

    When checking our server one can clearly see that curl is indeed installed and working as it should be (screen shot below)

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.