Twitter not working with Comments Plus

Like others on this forum, I can’t get Twitter to work with Comments Plus. It seems to need a little more detail in the Twitter section of the settings page for the plugin, as several people have asked for help on this. I’m getting the same error others reported:


Whoa there!

There is no request token for this page. That’s the special key we need from applications asking to use your Twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake.


I copied the consumer key and consumer secret from Twitter correctly, but don’t see anywhere to put the request token (or even know what it is). There’s a “Request Settings” section at the bottom of the “OAuth tool” tab of the app I created at dev.twitter.com, but I don’t know what “Request query” to use and don’t see it anywhere on this plugin’s settings page.

Any idea how to get this working? You can see it trying to work at the bottom of http://jasonkelly.com.

Thank you!

  • jasonkelly
    • New Recruit

    Thanks, Phil. I cleared cache and cookies, and it worked … for a moment. I turned off my machine, came back later, and it was broken again. I closed Firefox, reopened, but still Twitter kicks off the same error. The others are fine. It’s just Twitter.

    I’ll keep playing with it. If it’s never reliable, I’ll disable it in the settings menu. I wish, however, that the remaining tabs would expand to fill the space. The plugin just deletes the Twitter tab and leaves a blank space on the right, which looks like a missing tooth.

    Given the other problems reported in these forums with Twitter and this plugin, couldn’t somebody go back in and see if it could be improved?

  • Philip John
    • DEV MAN’s Apprentice

    Okay, then something else must be knocking it out of kilter. We have plenty of folks (including ourselves) using this successfully so there’s something specific to your install interfering here.

    To test that can you de-activate all plugins, revert to the default theme, clear cookies and cache and test it again please?

    Thanks,

    Phil

  • jasonkelly
    • New Recruit

    You may be right on something specific to our install, but our policy is that if something takes this much work to get going, we’re not interested. The point of plugins is to plug them in and have them work. After further researching the way the plugin broadcasts comments to Facebook and G+, we found that it was not very attractive, anyway, and so are just going to disable this and return to plain old, reliable WP comments with social networking buttons.

    The issue with the Comments Plus broadcast format on Facebook is this: The person’s comment appears as their primary comment on their Facebook wall, which is correct, but then the attached link text shown below in the Facebook update repeats the same comment text instead of showing a snippet from the post being commented on. Pretty unsophisticated. If the plugin can’t pull a snippet from the post a la straight Facebook updates or Twitter RSS broadcasts, it should just skip any text in the link attachment and show only the link and the forced image or included image.

    Thank you, again, for offering support, Phil. We’ll see if we can find something else on WPMU to improve our business.

  • Timothy
    • Chief Pigeon

    Hey Jasonkelly.

    The point of plugins is to plug them in and have them work.

    Unfortunately with any plugin or theme there can be conflicts, especially when use jQuery, APIs, etc. The only way to find the cause and fix it, is to go through the process Phil outlined. Its the only way to eliminate and locate.

    Thanks for the feedback there I will be sure to pass it onto the developer. :slight_smile:

  • Timothy
    • Chief Pigeon

    Did you check the keys and everything?

    Have you tested for conflicts yet?

    If not then please test in the default theme (Twenty Eleven) and with all other plugins turned off. This will let us know if there is a conflict somewhere.

    Let me know how you go.

    Thanks

  • tfbc
    • Site Builder, Child of Zeus

    have you gone to https://dev.twitter.com logged into your twitter account, mouse over your twitter name at top right, select my applications. under details tab it has

    Your access token

    It looks like you haven’t authorized this application for your own Twitter account yet. For your convenience, we give you the opportunity to create your OAuth access token here, so you can start signing your requests right away. The access token generated will reflect your application’s current permission level.

    or its going to list your access token info.

    then check your OAuth tool tab to be sure the settings are right there,

    also goto the @anywhere domain and be sure your domain is there listed under

    Currently Authorized Domains

    finally if that does not work, reset your keys, enter the new keys into your site and see if that works.

  • Fanus van Straten
    • Site Builder, Child of Zeus

    I did the reset but it still says: “There is no request token for this page. That’s the special key we need from applications asking to use your Twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake.”

  • PC
    • WPMU DEV Initiate

    Hiya Neil,

    Its sad that you had to give up on this one :-

    However, I am glad that you got it sorted out with another system :slight_smile: If there is anything you need on this thread, please feel free to post after reopening this thread and I would just be around.

    Thanks for being a great community member.

    Cheers

    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.